2 Replies Latest reply on May 24, 2010 1:02 PM by Anastasiya Bogachuk

    403 Error in Eclipse jBPM Process deployment

    Steve Larsen Newbie

      Using jBoss Tools 3.x in Eclipse and trying to deploy a process par was running into authentication issues (403 error). Trying all things on the Internet for the Server Deployer (e.g. jbpm-console/upload and jbpm-console/app/upload among a veriety of other suggestions) failed to correct. Then found an obscure JIRA comment regarding trying to deploy in authenticated environment required a different servlet (gpd-deployer/upload). Tried this and it worked.

       

      I'm a newbie and do not yet know all the terms or dependencies of the entire JBoss Tools and certainly do not have an understanding of the various "jar" files associated with different components of the Eclipse plug-ins (makes my head spin trying to follow some forum threads on "make sure x.jar is in xx directory...") but for what it's worth, I thought it interesting that this is not documented anywhere (I presume because from what I've read that it is assumed that you are working in an unauthenticated environment so there is no need to use credentials when deploying).

       

      Perhaps this can help someone else in the same situation (or someone in the know can respond with the "official" way if this is not correct).