0 Replies Latest reply on May 14, 2010 4:27 PM by Robert Goodwin

    Problem calling web service from within JBOSS EJB Service

    Robert Goodwin Newbie

      I have a simple web service sitting on our internal network.  I used SOAPUI to do a bit of testing,  generated the service classes from the WSDL , and wrote some java code to access the service.  All went as expected as I was able to create the service proxy classes and make calls.  Pretty simple stuff.  The only speed bump was getting java to trust the certificate from the machine providing the web service.  That was not a technical problem, but rather my lack of experience with SSL based web services.
      Now onto my problem.  I coded up a simple EJB service and deployed it into JBoss Application Server 4.3 (jbossas-4.3.0.GA_CP07) and now get the following error in the code that previously worked.

       

          12:21:50,235 WARN  [ServiceDelegateImpl] Cannot access wsdlURL: https://WS-Test/TestService/v2/TestService?wsdl

       

      I can access the wsdl file from a web browser running on the same machine as the application server using the URL in the error message.  I can execute the same code outside of jboss on the same box and it is able to access the web service fine.  I am at a loss as to where to go from here.  I turned on the debug logs in JBOSS and got nothing more than what I showed above.   I have done some searching on the net and found the same error in some questions, but those questions had no answers.  The web services classes where generated with JAX-WS 2.2 using the wsimport ant task and placed in a jar that is included in the ejb package.  JBoss is deployed in RHEL 5.4, where the standalone testing was done on Windows XP.  The JBoss bsersion is jbossas-4.3.0.GA_CP07.  Any ideas where to look for clues?

       

      Thanks,

      Rob

       

      After some searching, this looks like a simular problem to https://community.jboss.org/message/365432#365432

      But that had no responses.