2 Replies Latest reply on May 20, 2010 4:17 AM by Joris Lops

    rich:tooltip in rich:columns has no content

    Joris Lops Newbie

      Hello All,

       

      I try to use a rich:tooltip in a rich:columns component, I don't get it working properly. To be more precise: the tooltip appears but there is no content in it.

      To demonstrate my problem I made a simple example with rich:column and rich:columns. The rich:column tooltip is working but the rich:columns tooltip is not! In the log (a4j:logs) there is no error. I don't have any clue how to get this working.

       

       

      The xhtml file:                                                                                                                                                                                                 

      {code}

              <a4j:form>
                  <rich:messages/>
                  <a4j:log/>
                  <rich:dataTable value="#{Test2.model}" var="model" width="750">
                      <f:facet name="header">
                          <h:outputText value="Table Header"></h:outputText>
                      </f:facet>
                      <rich:column>
                          <f:facet name="header">
                              <h:outputText value="column" />
                          </f:facet>
                          <a4j:outputPanel layout="block">
                              <rich:toolTip direction="top-right" mode="ajax" showDelay="300"
                                            layout="block">
                                  <h:panelGrid columns="4">
                                      <f:facet name="header">
                                          <h:outputText value="Tooltip detail:" />
                                      </f:facet>
                                      <h:outputText value="Test!"/>
                                      <f:facet name="footer">
                                          <h:panelGroup>
                                              <h:outputText value="Tooltip footer " />
                                          </h:panelGroup>
                                      </f:facet>
                                  </h:panelGrid>
                              </rich:toolTip>
                              <h:outputText value="#{model[0]}"/>
                          </a4j:outputPanel>
                      </rich:column>
                      <!-- tooltip has no content -->
                      <rich:columns value="#{Test2.columns}" var="columns"
                                    index="ind" id="column#{ind}">
                          <f:facet name="header">
                              <h:outputText value="#{ind}" />
                          </f:facet>
                        
                          <a4j:outputPanel layout="block">
                              <rich:toolTip direction="top-right" mode="ajax" showDelay="300"
                                            layout="block">
                                  <h:panelGrid>
                                      <h:outputText value="Test!"/>
                                  </h:panelGrid>
                              </rich:toolTip>
                              <h:outputText value="#{model[ind]}"/>
                          </a4j:outputPanel>
                      </rich:columns>
                  </rich:dataTable>
              </a4j:form>

      {code}                                                                                                                

       

      Using rf 3.3.3.

       

      Thanks,

      Joris