3 Replies Latest reply on Jun 9, 2010 4:52 PM by Brian Hammond

    Could not load servlet class

    Brian Hammond Newbie

      I am new to JBoss, and I'm having what is probably a simple problem, but I haven't been able to solve it yet.  I am running JBoss 5.1.0 with Java SDK 1.6.0_20 on a Linux box.  I downloaded the JBoss source and built it.  The build seemed to go correctly, at least I didn't see any error messages.  When I run it, however, I get a consistent warning that JBoss couldn't load com.sun.xml.ws.transport.http.servlet/WSServlet.  Immediately after, I get a classNotFoundException for com.sun.xml.ws.transport.http.servlet.WSServletContextListener.  The warning is the first indication that something went wrong in the invokation.  I've checked and the jar file containing both those classes exists and is in the client folder.  I tried rebuilding JBoss, but it didn't seem to make any difference; I'm still getting the errors.  It appears that the error is preventing any of my deployments from succeeding.  Can anyone tell me what's causing the error and how I can fix it?

       

      Thanks for your help,

      Brian