9 Replies Latest reply on Apr 30, 2009 4:01 AM by Nick Belaevski

    a4j:commandButton not working

    praveen jain Novice

      Hi Experts,
      Im having a simple modelpanel ,from where i want to submit some values ,modelpanel is in seprate form.

      Here's my jsp code of data table

      <rich:panel rendered="#{mainBind.customWizard.slideIndex == 2}">
       <rich:panel
       style="height: 200; width:100%; padding: 8; background: #757575;">
       <t:panelGrid columns="2" style="background: #757575;">
       <t:column>
       <rich:spacer width="8px"></rich:spacer>
       </t:column>
       <t:column>
       <t:outputLabel value="Cluster Name:" />
       <br />
       <h:inputText style="width: 400px;" value="#{mainBind.customWizard.clusterName}" id="clstrname" ></h:inputText>
      
       <br />
       <t:outputLabel value="Description:" />
       <br />
       <t:inputTextarea style="width: 400px;" value="#{mainBind.customWizard.clusterName}" id="clstrdesc"></t:inputTextarea>
       <br />
       <h:selectBooleanCheckbox id="selboolean" value="true" />
       <h:outputLabel for="selboolean" value="Default cluser" />
       <br />
       <h:selectBooleanCheckbox id="crt" value="false" />
       <h:outputLabel for="crt" value="Create cluser only" />
      
       </t:column>
       </t:panelGrid>
       </rich:panel>
       </rich:panel>

      i want values of textbox ,selectbox in my beans.
      My problem is that when i click on this a4j:commandButton then no action occurs. i.e my backing bean method is not invoked, but if i put h:commandButton instead, eveything works fine.

      Can any one please tell me as to where am going wrong,
      If needed i can post the respective files.