7 Replies Latest reply on Jun 24, 2010 4:20 AM by jaikiran pai

    JBoss 6.0.0 M3 - Exploaded deployment in Eclipse suddenly fails with DeploymentException

    Jesper Tejlgaard Newbie

      Hi all

       

      I am using JBoss 6.0.0 M3 and have now spent several hours trying to solve a deployment exception, which appeared after modifying Maven and Eclipse project settings. I have great difficulties finding out, why my project is not deploying anymore.

       

      All I get from JBoss console output is this:

       

      15:50:42,994 INFO  [org.jboss.bootstrap.impl.base.server.AbstractServer] JBossAS [6.0.0.20100429-M3 "Neo"] Started in 51s:904ms
      15:51:25,279 ERROR [org.jboss.kernel.plugins.dependency.AbstractKernelController] Error installing to PreReal: name=vfs:///Users/tejl/Documents/IntraMed/galileo-workspace/.metadata/.plugins/org.jboss.ide.eclipse.as.core/JBoss_6.0_standard_-_without_JRebel/deploy/v7-ear.ear state=PostClassLoader mode=Manual requiredState=PreReal: org.jboss.deployers.spi.DeploymentException: No module with relative path v7-ejb-1.0-SNAPSHOT.jar found  in set of modules for vfs:///Users/tejl/Documents/xx/galileo-workspace/.metadata/.plugins/org.jboss.ide.eclipse.as.core/JBoss_6.0_standard_-_without_JRebel/deploy/v7-ear.ear [/v7-ejb-1.0-SNAPSHOT.jar, /v7-wicket-war-1.0-SNAPSHOT.war, /v7-jsf-war-1.0-SNAPSHOT.war]
          at org.jboss.deployment.ModuleNameDeployer.establishUniqueModuleName(ModuleNameDeployer.java:163) [:6.0.0.20100429-M3]
          at org.jboss.deployment.ModuleNameDeployer.deploy(ModuleNameDeployer.java:118) [:6.0.0.20100429-M3]
          at org.jboss.deployers.plugins.deployers.DeployerWrapper.deploy(DeployerWrapper.java:179) [:2.2.0.Alpha4]
          at org.jboss.deployers.plugins.deployers.DeployersImpl.doDeploy(DeployersImpl.java:1857) [:2.2.0.Alpha4]
          at org.jboss.deployers.plugins.deployers.DeployersImpl.doInstallParentFirst(DeployersImpl.java:1575) [:2.2.0.Alpha4]
          at org.jboss.deployers.plugins.deployers.DeployersImpl.doInstallParentFirst(DeployersImpl.java:1628) [:2.2.0.Alpha4]
          at org.jboss.deployers.plugins.deployers.DeployersImpl.install(DeployersImpl.java:1516) [:2.2.0.Alpha4]
          at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:377) [jboss-dependency.jar:2.2.0.Alpha9]
          at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:2042) [jboss-dependency.jar:2.2.0.Alpha9]
          at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:1081) [jboss-dependency.jar:2.2.0.Alpha9]
          at org.jboss.dependency.plugins.AbstractController.executeOrIncrementStateDirectly(AbstractController.java:1320) [jboss-dependency.jar:2.2.0.Alpha9]
          at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1244) [jboss-dependency.jar:2.2.0.Alpha9]
          at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1137) [jboss-dependency.jar:2.2.0.Alpha9]
          at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:937) [jboss-dependency.jar:2.2.0.Alpha9]
          at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:652) [jboss-dependency.jar:2.2.0.Alpha9]
          at org.jboss.deployers.plugins.deployers.DeployersImpl.change(DeployersImpl.java:2008) [:2.2.0.Alpha4]
          at org.jboss.deployers.plugins.deployers.DeployersImpl.process(DeployersImpl.java:1101) [:2.2.0.Alpha4]
          at org.jboss.deployers.plugins.main.MainDeployerImpl.process(MainDeployerImpl.java:679) [:2.2.0.Alpha4]
          at org.jboss.system.server.profileservice.repository.MainDeployerAdapter.process(MainDeployerAdapter.java:117) [:6.0.0.20100429-M3]
          at org.jboss.system.server.profileservice.hotdeploy.HDScanner.scan(HDScanner.java:409) [:6.0.0.20100429-M3]
          at org.jboss.system.server.profileservice.hotdeploy.HDScanner.run(HDScanner.java:294) [:6.0.0.20100429-M3]
          at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441) [:1.6.0_20]
          at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317) [:1.6.0_20]
          at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150) [:1.6.0_20]
          at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:98) [:1.6.0_20]
          at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(ScheduledThreadPoolExecutor.java:181) [:1.6.0_20]
          at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:205) [:1.6.0_20]
          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_20]
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_20]
          at java.lang.Thread.run(Thread.java:637) [:1.6.0_20]

       

      Does anyone have a clue of where to find the error?

        • 1. Re: JBoss 6.0.0 M3 - Exploaded deployment in Eclipse suddenly fails with DeploymentException
          jaikiran pai Master
          org.jboss.deployers.spi.DeploymentException: No module with relative path v7-ejb-1.0-SNAPSHOT.jar found  in set of modules for vfs:///Users/tejl/Documents/xx/galileo-workspace/.metadata/.plugins/org.jboss.ide.eclipse.as.core/JBoss_6.0_standard_-_without_JRebel/deploy/v7-ear.ear [/v7-ejb-1.0-SNAPSHOT.jar, /v7-wicket-war-1.0-SNAPSHOT.war, /v7-jsf-war-1.0-SNAPSHOT.war]

           

          Looks like a bug. The code is actually trying to generate a EE6 "module name". Given the module path "v7-ejb-1.0-SNAPSHOT.jar"  it's trying to find the metadata associated with it. However, looks the the map containing the module metadata is keyed with an additional "/" character as shown in that log. Can you attach a simple application which reproduces this?

          • 2. Re: JBoss 6.0.0 M3 - Exploaded deployment in Eclipse suddenly fails with DeploymentException
            jaikiran pai Master

            Can you also post your application.xml contents? I think you are setting the module names in there, prefixed with a "/". If so, then try getting rid of that "/" from there.

            • 3. Re: JBoss 6.0.0 M3 - Exploaded deployment in Eclipse suddenly fails with DeploymentException
              Jesper Tejlgaard Newbie

              First of all, I have to admit that my project is bloatet because being a prototype.

               

              application.xml looks fine to me:


              <?xml version="1.0" encoding="UTF-8"?>
              <application xmlns="http://java.sun.com/xml/ns/javaee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/application_5.xsd" version="5">
                <description>All the common jars dependencies are stored in the
                                              lib
                                              directory</description>
                <display-name>non-redundant-libs</display-name>
                <module>
                  <ejb>v7-ejb-1.0-SNAPSHOT.jar</ejb>
                </module>
                <module>
                  <web>
                    <web-uri>v7-jsf-war-1.0-SNAPSHOT.war</web-uri>
                    <context-root>/v7prototype-jsf</context-root>
                  </web>
                </module>
                <module>
                  <web>
                    <web-uri>v7-wicket-war-1.0-SNAPSHOT.war</web-uri>
                    <context-root>/v7prototype-wicket</context-root>
                  </web>
                </module>
                <library-directory>lib</library-directory>
              </application>

               


              But to make it worse, then I am using Maven to build the application. Related Maven config is:

               

                   <profile>
                          <id>JavaEE6</id>
                          <activation>
                              <activeByDefault>false</activeByDefault>
                          </activation>

               

                          <build>
                              <plugins>
                                  <plugin>
                                      <groupId>org.apache.maven.plugins</groupId>
                                      <artifactId>maven-ear-plugin</artifactId>
                                      <version>2.4.1</version>
                                      <configuration>
                                          <displayName>non-redundant-libs</displayName>
                                          <description>All the common jars dependencies are stored in the
                                              lib
                                              directory</description>
                                          <version>5</version>
                                          <defaultLibBundleDir>lib</defaultLibBundleDir>

               

                                          <modules>
                                              <ejbModule>
                                                  <groupId>dk.xxx.cso.v7prototype</groupId>
                                                  <artifactId>v7-ejb</artifactId>
                                                  <bundleFileName>v7-ejb-1.0-SNAPSHOT.jar</bundleFileName>
                                                  <bundleDir>/</bundleDir>
                                              </ejbModule>
                                              <webModule>
                                                  <groupId>dk.xxx.cso.v7prototype</groupId>
                                                  <artifactId>v7-jsf-war</artifactId>
                                                  <contextRoot>/v7prototype-jsf</contextRoot>
                                                  <bundleFileName>v7-jsf-war-1.0-SNAPSHOT.war</bundleFileName>
                                                  <bundleDir>/</bundleDir>
                                              </webModule>
                                              <webModule>
                                                  <groupId>dk.xxx.cso.v7prototype</groupId>
                                                  <artifactId>v7-wicket-war</artifactId>
                                                  <contextRoot>/v7prototype-wicket</contextRoot>
                                                  <bundleFileName>v7-wicket-war-1.0-SNAPSHOT.war</bundleFileName>
                                                  <bundleDir>/</bundleDir>
                                              </webModule>
                                          </modules>
                                          <!--
                                              HACK: Include legal muck from maven-remote-resources-plugin
                                          -->
                                          <resourcesDir>${project.build.outputDirectory}</resourcesDir>
                                      </configuration>
                                  </plugin>
                              </plugins>
                          </build>
                      </profile>

               

              I don't know which one kicks in for the exploaded deployment on JBoss. I might have to experiment some more with this.

              I'll try to create a simpler sample project later reproducing the error. The current project is too bloatet to upload.

              • 4. Re: JBoss 6.0.0 M3 - Exploaded deployment in Eclipse suddenly fails with DeploymentException
                Jesper Tejlgaard Newbie

                Don't know if this information is of any knowledge to you. But observation is valid.

                I tried the strategy of restarting without committing all my latest changes.

                1) Got rid of my prototype project(s) from Eclipse workspace.

                2) Checkout Maven project(s) again

                3) deployed.... same error

                 

                Then tried another JBoss server profile. Configured default in Eclipse instead of standard.

                4) Deployed on default .... same error

                 

                Could it be, that I have done od things to my Eclipse configuration?

                • 5. Re: JBoss 6.0.0 M3 - Exploaded deployment in Eclipse suddenly fails with DeploymentException
                  jaikiran pai Master

                  It's difficult to tell why your application is running into this issue, without having access to your application. If you could attach a simple app which reproduces this, then it would be easier to fix it (and maybe even provide a workaround). As for the Maven pom.xml files, they don't come into picture once the .ear file has been created.

                  • 6. Re: JBoss 6.0.0 M3 - Exploaded deployment in Eclipse suddenly fails with DeploymentException
                    Jesper Tejlgaard Newbie

                    Hi Jaikiran

                     

                    I have not been able to reproduce the  problem building a new project. I however fund the source of the deployment problem  in the exploaded deployment directory [my workspace]/.metadata/.plugins/org.jboss.ide.eclipse.as.core/JBoss_6.0_standard_-_without_JRebel/deploy. The file v7-ear.ear/META-INF/application.xml contained '/' as first character in all modules, i.e.

                     

                    <?xml version="1.0" encoding="ASCII"?>
                    <application xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://java.sun.com/xml/ns/javaee" xmlns:application="http://java.sun.com/xml/ns/javaee/application_5.xsd" xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/application_5.xsd" version="5">
                      <display-name>v7-ear</display-name>
                      <module>
                        <web>
                          <web-uri>/v7-wicket-war-1.0-SNAPSHOT.war</web-uri>
                          <context-root>/v7prototype-wicket</context-root>
                        </web>
                      </module>
                      <module>
                        <ejb>/v7-ejb-1.0-SNAPSHOT.jar</ejb>
                      </module>
                      <module>
                        <web>
                          <web-uri>/v7-jsf-war-1.0-SNAPSHOT.war</web-uri>
                          <context-root>/v7prototype-jsf</context-root>
                        </web>
                      </module>
                      <library-directory>lib</library-directory>
                    </application>

                     

                     

                    I would guess the application.xml file is generated by WST (with M2Eclipse integration). My pom.xml files looks correct, so I have no clue of why these extra '/' are added. Never the less. I don't need the project anymore as we skipped the prototype and started a new project. Thanks for all your help.

                    • 7. Re: JBoss 6.0.0 M3 - Exploaded deployment in Eclipse suddenly fails with DeploymentException
                      jaikiran pai Master

                      That explains it. Thanks for posting the application.xml contents. Let me see if we can handle this in a better way.