5 Replies Latest reply on Jun 15, 2010 3:03 PM by Tom Fennelly

    Problem transforming nested document xml-java

    rainer knupfer Newbie

      Hi,

      I have nested document that needs to be parsed and converted into a java structure. For this I used the smooks project and I managed very well. As soon I deploy on jboss-esb 4.8 i get errors. It seems the jboss-esb plugin is not the same as i.e. smooks 1.3.1. In particular it has (jboss-esb) problem with references like <jb:wiring beanIdRef="intervalList" property="interval" />

       

      Even trying to build the hierarchy...it goes until the 2nd level and problems arises...

       

      The question: how differs jboss-smooks from the "official" release. Why is not possible to parse complex files, where are the limits for putting a product like jboss-esb into production ?

       

      Thx

       

       

       

      Document:

       

      <?xml version = '1.0' encoding = 'ISO-8859-1'?>
      <ScheduleMessage DtdVersion="2" DtdRelease="3">
          <MessageIdentification v="IE_1_22_20100604"/>
          <MessageVersion v="5"/>
          <MessageType v="A01"/>
          <ProcessType v="A13"/>
          <ScheduleClassificationType v="A01"/>
          <SenderIdentification v="12XAET-HANDEL--3" codingScheme="A01"/>
          <SenderRole v="A01"/>
          <ReceiverIdentification v="10XCH-SWISSGRIDC" codingScheme="A01"/>
          <ReceiverRole v="A04"/>
          <MessageDateTime v="2010-06-07T06:14:49Z"/>
          <ScheduleTimeInterval v="2010-06-03T22:00Z/2010-06-04T22:00Z"/>
          <ScheduleTimeSeries>
              <SendersTimeSeriesIdentification v="FPBG_A2AA"/>
              <SendersTimeSeriesVersion v="1"/>
              <BusinessType v="A02"/>
              <Product v="8716867000016"/>
              <ObjectAggregation v="A01"/>
              <InArea v="10YCH-SWISSGRIDZ" codingScheme="A01"/>
              <OutArea v="10YCH-SWISSGRIDZ" codingScheme="A01"/>
              <InParty v="17X100A100R0186I" codingScheme="A01"/>
              <OutParty v="12XAET-HANDEL--3" codingScheme="A01"/>
              <MeasurementUnit v="MAW"/>
              <Period>
                  <TimeInterval v="2010-06-03T22:00Z/2010-06-04T22:00Z"/>
                  <Resolution v="PT15M"/>
                  <Interval>

        • 2. Re: Problem transforming nested document xml-java
          Tom Fennelly Master

          The version of Smooks in the ESB is unmodified from the same version in the offical release.

           

          What error are you getting?  What does your ESB config look like?

          • 3. Re: Problem transforming nested document xml-java
            rainer knupfer Newbie

            Hi, The console doesn't say a lot. The problem arises when i try to wire a reference bean

             

            <jb:wiring beanIdRef="scheduleTimeSeriesList" property="scheduleTimeSeries"/></jb:bean>

             

            The same configuration is fine while using smooks project libs outside the container

             

            Attached find the esb conf.

            Thx

             

             

            09:16:25,118 WARN  [ActionProcessingPipeline] No fault address defined for fault message! To: JMSEpr [ PortReference < <
            wsa:Address jms:127.0.0.1:1099#queue/ftp_esb/>, <wsa:ReferenceProperties jbossesb:java.naming.factory.initial : org.jnp.
            interfaces.NamingContextFactory/>, <wsa:ReferenceProperties jbossesb:java.naming.provider.url : 127.0.0.1:1099/>, <wsa:R
            eferenceProperties jbossesb:java.naming.factory.url.pkgs : org.jnp.interfaces/>, <wsa:ReferenceProperties jbossesb:desti
            nation-type : queue/>, <wsa:ReferenceProperties jbossesb:destination-name : queue/ftp_esb/>, <wsa:ReferenceProperties jb
            ossesb:specification-version : 1.1/>, <wsa:ReferenceProperties jbossesb:connection-factory : ConnectionFactory/>, <wsa:R
            eferenceProperties jbossesb:message-selector : source='fromFTPAction'/>, <wsa:ReferenceProperties jbossesb:persistent :
            true/>, <wsa:ReferenceProperties jbossesb:acknowledge-mode : AUTO_ACKNOWLEDGE/>, <wsa:ReferenceProperties jbossesb:trans
            acted : false/>, <wsa:ReferenceProperties jbossesb:type : urn:jboss/esb/epr/type/jms/> > ] MessageID: c66e3f7f-27d9-4158
            -8488-41c6872c4c1a RelatesTo: jms:correlationID#c66e3f7f-27d9-4158-8488-41c6872c4c1a

            • 4. Re: Problem transforming nested document xml-java
              rainer knupfer Newbie

              Hi,

              I tried to load into an action the configFile and instantiate a smook instance inside a own Action (instead of using org.jboss.soa.esb.smooks.SmooksAction)

               

              When I run i get following error:

               

              20:03:03,935 ERROR [SmooksDOMFilter] Failed to apply processing unit [org.milyn.javabean.BeanInstancePopulator] to [org:
              milyn:smooks:unknowndoc:/ScheduleMessage].
              org.milyn.cdr.SmooksConfigurationException: Bean [scheduleMessage] configuration invalid.  Bean setter method [setScheduleTimeSeries(java.util.ArrayList)] not found on type [ch.swissgrid.bgm2.service.schedule.v1.ScheduleMessage].  You may n
              eed to set a 'decoder' on the binding config.
                      at org.milyn.javabean.BeanInstancePopulator.setPropertyValue(BeanInstancePopulator.java:521)

               

               

              my setter exists!

               

              The same code run inside a Main Class with same smooks-configuration file works fine!

              • 5. Re: Problem transforming nested document xml-java
                Tom Fennelly Master

                Sounds like a classloader issue perhaps... not sure.

                 

                If you could break this down... remove any sensitive info from it... modify one of the quickstarts and attach it I might be able to check it out for you.