2 Replies Latest reply on May 5, 2009 1:55 PM by David Andreasson

    rich:ListShuttle - Trouble copying items in msie 7.0 with Go

    David Andreasson Newbie

      For some reason the selection and copying of multiple items in the rich:ListShuttle component doesn't seem to work properly in MSIE 7.0 with Google Toolbar or Google Desktop installed.

      If I uninstall the Google Toolbar/Google Desktop it works properly again.

      I guess this is most likely a problem with the Google stuff, but since it affects the rich:ListShuttle I thought I should mention it here.

        • 1. Re: rich:ListShuttle - Trouble copying items in msie 7.0 wit
          Tsikhon Kuprevich Newbie

          Hi!

          I've just tried the case you have mentioned and it worked fine. What is your environment? Could you please upload your sample application?

          Best Regards,
          Tsikhon Kuprevich

          • 2. Re: rich:ListShuttle - Trouble copying items in msie 7.0 wit
            David Andreasson Newbie

            It was one of the testers at the company I work for that noticed the problem and unfortunately I won't be at the office again until Monday. I use a Mac at home, so at the moment I don't have access to the same environment.

            The environment where the issue occurred was WinXP with MSIE 7 and Google Toolbar. It also occurred on another machine that ran WinXP with MSIE 7 and Google Desktop. With Google Toolbar uninstalled the issue went away.

            The application was just a simple web page with a ListShuttle where the source list was filled with a number of strings. With Google Toolbar installed it was more or less impossible to select multiple items in the source list. It was possible to select one item, but then when we tried to select more items (with CTRL pressed down) it immediately copied the first selected item to the target list. Also the selection looked a bit weird.

            I'm sorry I can't provide you with more details at the moment and if no one else can reproduce it, then it was probably just some issue with the environment, but since it disappeared when we removed Google Desktop I just thought I aught to mention it.