4 Replies Latest reply on Jun 24, 2010 4:00 AM by Joydeep Sarkar

    Clustering with UDP

    Joydeep Sarkar Newbie

      Dear All,

       

      I am trying to form a cluster with 2 physical machines using UDP in Linux box. The goal is to achieve singleton clustering. Due to scarcity of Servers, I am using 2 Machines where two instances are already running in non-clustered mode. Let me elaborate the scenario below,

       

      Server A is running instance A1.

      Server B is running instance B1.

       

      In both the servers I made a duplicate of  "All" instance and renamed the same (as masterslave) which I will refer as A2 and B2.

      Now, I started both A2 and B2 with the same UDP address but they did not recognize each other. I did not get any exception either.

       

      Following is the command that I used,

      ./run.sh -c masterslave -u 233.3.4.5 -Djboss.service.binding.set=ports-01 -Djboss.messaging.ServerPeerID=1

       

      I see the following message only in both the server's log,

      12:35:11,590 INFO  [GroupMember] I am (127.0.0.1:36935)
      12:35:11,590 INFO  [GroupMember] New Members : 1 ([127.0.0.1:36935])
      12:35:11,590 INFO  [GroupMember] All Members : 1 ([127.0.0.1:36935])

       

      I am not really sure why the cluster is not being formed. Could anyone please help me with the same?

       

      Sorry, forgot to mention, I am using JBoss5.1.0GA.

       

      TIA,

      Joydeep

        • 1. Re: Clustering with UDP
          Sandesh Satam Newbie

          It's seems like your hostname is binded to localhost, check your hosts file for hostname.

           

          ~SS

          • 2. Re: Clustering with UDP
            Joydeep Sarkar Newbie

            Hi,

             

            In order to bind the IP I used '-b' option as follows. Even though all the services are bound to the respective IPs, the cluster is still not formed.

             

            ./run.sh -b 10.1.0.236 -c masterslave -u 233.3.4.5 -Djboss.service.binding.set=ports-01 -Djboss.messaging.ServerPeerID=1
            14:07:46,618 INFO  [GroupMember] I am (10.1.0.71:47136)
            14:07:46,619 INFO  [GroupMember] New Members : 1 ([10.1.0.71:47136])
            14:07:46,619 INFO  [GroupMember] All Members : 1 ([10.1.0.71:47136])

             

            ./run.sh -b 10.1.0.71 -c masterslave -u 233.3.4.5 -Djboss.service.binding.set=ports-01 -Djboss.messaging.ServerPeerID=1

            30:04,979 INFO  [GroupMember] I am (10.1.0.236:56131)
            14:30:04,979 INFO  [GroupMember] New Members : 1 ([10.1.0.236:56131])
            14:30:04,979 INFO  [GroupMember] All Members : 1 ([10.1.0.236:56131])

             

            Is there any possibility that the UDP address I am using is wrong? In that case how do I check that?

            Is there anything else that I need to check?

             

            Regards,

            Joydeep

            • 3. Re: Clustering with UDP
              Joydeep Sarkar Newbie

              Hi,

               

              Not sure if this is any helpful info, but when I ping 233.3.4.5 on either machines, I receive reply only from the host IP. I tried the same with 228.8.8.8 as well, but still the same story.

              I wonder if it has anything to do with configuration of UDP inside the instance.

               

              Regards,

              Joydeep
               

              • 4. Re: Clustering with UDP
                Joydeep Sarkar Newbie

                Hi,

                 

                Finally I have managed to form the cluster.

                The reason was silly though.. the UDP addresses that I was trying out, were not configured.

                 

                Thanks a ton for the support.

                 

                Regards,

                Joydeep