8 Replies Latest reply on Jul 4, 2010 11:52 PM by auy za

    Jboss6.0.0-M3 with mod_cluster 1.0.3GA cant access application

    auy za Newbie

      Hi all,

       

      pls help to verify my config below. after start apache and jboss everything seems fine. but when i access application context it doesnt show anything.

       

      httpd.conf

      LoadModule proxy_module modules/mod_proxy.so
      LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
      LoadModule slotmem_module modules/mod_slotmem.so
      LoadModule manager_module modules/mod_manager.so
      LoadModule proxy_cluster_module modules/mod_proxy_cluster.so
      LoadModule advertise_module modules/mod_advertise.so
      Listen 192.168.216.128:6666
      <VirtualHost 192.168.216.128:6666>
        <Directory />
           Order deny,allow
           Deny from all
           Allow from all
        </Directory>
      KeepAliveTimeout 60
      MaxKeepAliveRequests 0 
      ManagerBalancerName mycluster
      AdvertiseFrequency 5
      </VirtualHost>
      <Proxy balancer://mycluster>
        BalancerMember http://192.168.216.128:8080 loadfactor=1
      </Proxy>
      ProxyPass / balancer://mycluster/
      ProxyPassMatch ^(/.*\.gif)$ !
      <Location /mod_cluster-manager>
        SetHandler mod_cluster-manager
        Order deny,allow
        Deny from all
        Allow from all
      </Location>
      here is apache log
      [Wed Jun 30 15:24:48 2010] [debug] proxy_util.c(1806): proxy: grabbed scoreboard slot 0 in child 15605 for worker http://192.168.216.128:8080
      [Wed Jun 30 15:24:48 2010] [debug] proxy_util.c(1825): proxy: worker http://192.168.216.128:8080 already initialized
      [Wed Jun 30 15:24:48 2010] [debug] proxy_util.c(1902): proxy: initialized worker 0 in child 15605 for (192.168.216.128) min=0 max=25 smax=25
      [Wed Jun 30 15:24:48 2010] [debug] proxy_util.c(1806): proxy: grabbed scoreboard slot 2 in child 15605 for worker proxy:reverse
      [Wed Jun 30 15:24:48 2010] [debug] proxy_util.c(1825): proxy: worker proxy:reverse already initialized
      [Wed Jun 30 15:24:48 2010] [debug] proxy_util.c(1902): proxy: initialized worker 2 in child 15605 for (*) min=0 max=25 smax=25
      [Wed Jun 30 15:24:48 2010] [debug] proxy_util.c(1791): proxy: worker http://192.168.216.128:8080 already initialized
      [Wed Jun 30 15:24:48 2010] [notice] child pid 15501 exit signal Segmentation fault (11)
      [Wed Jun 30 15:24:49 2010] [debug] mod_proxy_cluster.c(587): update_workers_node starting
      [Wed Jun 30 15:24:49 2010] [debug] mod_proxy_cluster.c(606): update_workers_node done
      [Wed Jun 30 15:24:49 2010] [debug] mod_proxy_cluster.c(587): update_workers_node starting
      [Wed Jun 30 15:24:49 2010] [debug] mod_proxy_cluster.c(606): update_workers_node done
      deploy/mod_cluster.sar/META-INF/mod_cluster-jboss-beans.xml
      <bean name="ModClusterListener" class="org.jboss.modcluster.catalina.CatalinaEventHandlerAdapter" mode="On Demand">
          <constructor>
            <!-- To use the HA singleton version of mod_cluster, change this injection to HAModClusterService -->
            <parameter class="org.jboss.modcluster.ContainerEventHandler"><inject bean="HAModClusterService"/></parameter>
            <parameter class="javax.management.MBeanServer"><inject bean="JMXKernel" property="mbeanServer"/></parameter>
          </constructor>
      </bean>
      <property name="proxyList">${jboss.mod_cluster.proxyList:192.168.216.128:6666}</property>

       

      deploy/jbossweb.sar/server.xml   

      <Listener className="org.jboss.web.tomcat.service.deployers.MicrocontainerIntegrationLifecycleListener"

                   delegateBeanName="ModClusterListener" failIfBeanMissing="false" warnIfBeanMissing="false"/>

       

      deploy/jbossweb.sar/META-INF/jboss-beans.xml            

      <depends>HAModClusterService</depends>

       

      does anyone know about this please help to advise?

       

      Thank you in advance.

      AUY.