4 Replies Latest reply on Jul 6, 2010 1:37 PM by Thiago Assis

    No META-INF/application.xml found

    Thiago Assis Newbie

      Hi,

       

      I'm trying to deploy an app using jboss 4.2.2 GA, jdk 1.5.12 and eclipse 3.5 (galileo).

      I used do deploy a closed ear and everything worked fine, now i have to use an

      exploded ear but it's not working. I'm getting this error:

       

      2010-07-05 11:37:00,866 ERROR [org.jboss.deployment.MainDeployer]  Could not initialise deployment: file:/application/jboss-4.2.2.GA/server/default/deploy/application.ear/
      org.jboss.deployment.DeploymentException: No META-INF/application.xml  found
      at org.jboss.deployment.EARDeployer.init(EARDeployer.java:146)

       

      This error is on linux, on windows it works just fine.

      The application.xml is there.

       

      Any ideas?

       

      Thanks in advance.

        • 1. Re: No META-INF/application.xml found
          jaikiran pai Master

          Are you sure you have META-INF (case sensitive) folder containing application.xml, in the .ear file?

          • 3. Re: No META-INF/application.xml found
            jaikiran pai Master

            Post the output of:

             

            ls -l /application/jboss-4.2.2.GA/server/default/deploy/application.ear/

             

             

            How are you starting the server? Are you using any specific user for starting the server? What kind of permissions does that user have on the deploy/application.ear folder?

            • 4. Re: No META-INF/application.xml found
              Thiago Assis Newbie

              ls output is:


              atlantis:cpept:[/application/jboss-4.2.2.GA/bin]  >  ls -l   /application/jboss-4.2.2.GA/server/default/deploy/application.ear/
              total 24912
              rwxrwx--   1 y1xg     tgdpep     92015 Jun 29  11:17  antlr-runtime.jar
              rwxrwx--   1 y1xg     tgdpep     559696 Jun 29 11:17  drools-compiler.jar
              rwxrwx--   1  y1xg     tgdpep   1074902 Jun 29 11:17  drools-core.jar
              rwxrwx--    1 y1xg     tgdpep     69223 Jun 29 11:17  gentlyWEB-utils-1.1.jar
              rwxrwx--   1 y1xg     tgdpep    258160 Jun 29 11:17   jai_codec.jar
              rwxrwx--   1 y1xg     tgdpep   1900631 Jun  29 11:17  jai_core.jar
              rwxrwx--   1 y1xg     tgdpep     134342 Jun 29 11:17  jboss-el.jar
              rwxrwx--   1 y1xg      tgdpep   1100987 Jun 29 11:17  jboss-seam.jar
              rwxrwx--   1  y1xg     tgdpep    668249 Jun 29 11:17  jbpm-jpdl.jar
              rwxrwx--    1 y1xg     tgdpep    203521 Jun 29 11:17  JoSQL-1.9.jar
              rwxrwx--    1 y1xg     tgdpep    418943 Jun 29 11:17 ldap.jar
              drwxrwx---   2  y1xg     tgdpep      4096 Jul  2 16:00 lib
              drwxrwx---   2 y1xg      tgdpep      4096 Jul  2 16:00 META-INF
              rwxrwx--   1 y1xg      tgdpep   1117312 Jun 29 11:17  mvel14.jar
              rwxrwx--   1  y1xg     tgdpep    421601 Jun 29 11:17  quartz.jar
              rwxrwx--    1 y1xg     tgdpep    174815 Jun 29 11:17  richfaces-api.jar
              rwxrwx--    1 y1xg     tgdpep   4438278 Jun 29 11:17  richfaces-ui.jar
              drwxrwx---   4 y1xg     tgdpep      4096 Jul  2 16:01  application-ejb.jar
              drwxrwx---  10 y1xg     tgdpep     12288 Jul  2  16:03 application.war

               

               

              I'm starting  jboss through init.d. The user is a normal one, no special permissions, i  think

              the user has write permission to the application folder.

               

              Thanks  again