1 Reply Latest reply on Jul 25, 2010 1:19 AM by MiNG Jason

    CAS on JBoss GA

    Fons Maathuis Newbie

      As I want to deploy CAS 3.4.2 on a JBoss 5.1.0-GA I started looking for documentation about this subject. There seems to be no up-to-date documentation about using these versions, so I started with trial-and-error. I couldn't get it to work correctly.


      Then I tried to deploy CAS 3.4.2 on a Tomcat 6.0 server, I could find some documentation about that. Making a few adaptions, rebuilding the war-file with maven and deploying it on the server I got it working fine. So I took it a step further, I've installed openLDAP, connected that to CAS and I could logon with LDAP-authentication. This working situation I tried to copy to the JBoss server, but I still got the same errors and warnings.


      The first one I get is about a persistence. JBoss wants to have a non-jta-data-source for a RESOURCE_LOCAL enabled persistence. Defining a persistence-definition doesn't solve this. Changing RESOURCE_LOCAL to JTA doesn't either.


      Then I got an error concerning SLF4J-logging. By renaming some SLF4J-jarfiles to .bak I could at least start up without getting these errors.


      Does anybody has any expirience deploying CAS (whatever version) on JBoss? Is there any up-to-date documentation about this proces?

        • 1. Re: CAS on JBoss GA
          MiNG Jason Newbie

          I got a same problem like you.


          The first one have many way to solve:

          1. delete the persistence.xml

          2. add tag <non-jta-data-sorce /> in persistence unit.

          3. add a data-source named CasPersistence


          But the second one I still have no idea about it until now.

          In other discuss, someone says that delete the following file in the war file:

          I have tried too. After delete these jar files, the deploying process will halt on loading log4j configuration (log4j.xml), still can not deploy.
          To solve these problems I suggest that you should deploy the CAS old version 3.3.5(.1)  or deploy on the JBoss4.
          The conflict just happen on CAS 3.4.x with JBoss5.x (or newer)