8 Replies Latest reply on Jul 15, 2010 10:01 AM by Thorsten Kunz

    Helios does not recognize JBoss 6.0 Runtime as JEE6 environment

    Thorsten Kunz Novice

      Hi there,

       

      I installed the most recent JBoss Tools nightly build for Helios. Now when I try to create e.g. an EJB Project and set the "Target Runtime" to "JBoss 6.0 Runtime" based on a JBAS 6.0-M3 I loose the option to set the "EJB Module Version" to 3.1. Only 3.0 is available.

      Same is true for "Enterprise Application Projects". I can only set the the "EAR Version" to 5.0. No 6.0 is available.

       

      Now when I set the "Target Runtime" to my Glassfish 3 Runtime I have all the JEE6 options available.

       

      Is there a workaround for that to enable JEE6 stuff for the JBoss 6 Runtime or is it a bug in the Tools code?

       

      Thanks