1 Reply Latest reply on Jul 20, 2010 3:28 AM by raju k

    Configure Custom mode(Edit_Defaults) in Vignette Application Portal 7.3 with JBOSS4.2.3GA

    raju k Newbie

      HI

      i am using JBOSS 4.2.3 GA with Vignette Application portal7.3.


      I have given entry in Portlet.xml for configuring Custom mode.

       

    • <portlet-app>  
    • <portlet> 
    •     <description xml:lang="EN">CustomModePortlet</description> 
    •     <portlet-name>CustomModePortlet</portlet-name> 
    •     <display-name xml:lang="EN">CustomModePortlet</display-name> 
    •     <portlet-class>com.yash.blog.portlet.CustomModePortlet</portlet-class> 
    •  
    •     <expiration-cache>0</expiration-cache> 
    •  
    •     <supports> 
    •       <mime-type>text/html</mime-type> 
    • <portlet-mode>view</portlet-mode> 
    • <portlet-mode>edit</portlet-mode> 
    • <portlet-mode>EDIT_DEFAULTS</portlet-mode> 
    • <portlet-mode>help</portlet-mode> 
    •     </supports> 
    •  
    •     <supported-locale>en</supported-locale> 
    •  
    •     <portlet-info> 
    •       <title>CustomModePortlet</title> 
    •       <short-title>CustomModePortlet</short-title> 
    •       <keywords>CustomModePortlet</keywords> 
    •     </portlet-info> 
    •  
    •     <portlet-preferences><preference> 
    •             <name>currentstylesheet</name> 
    •             <value>maroon</value> 
    •         </preference> 
    •     </portlet-preferences> 
    •  
    •  
    •  
    •   </portlet> 
    •  
    • <custom-portlet-mode> 
    •     <portlet-mode>EDIT_DEFAULTS</portlet-mode> 
    • </custom-portlet-mode> 
    • </portlet-app>     
    • But when i deploy war file in Jboss Server then Custom mode icon  not appearing in view mode.

      Any settings required for the custom mode in Vignette portal?
      or Vignette portal not supported for custom mode?


      Please help if any body knows about.

      Thanks In Advance
      Raju.K