This content has been marked as final. Show 4 replies
I found that there may be some confussion in class names defined for DataScroller in 4.0.0.A2.
As you can see on attached image, buttons "First", "Fast Rewind", "Fast Forward" and "Last" have defined classes "rf-ds-btn" and "rf-ds-l" or "rf-ds-r".
IDs for this buttons takes in consideration the exact type of given button: form:scroller1_ds_f, form:scroller1_ds_fr, form:scroller1_ds_ff or form:scroller1_ds_l.
It will be nice to have also class names for exact selection of such buttons, instead you have to use CSS3 selectors (such as :nth-child, :first, :last) to select such elements, but this isn't straightforward if you disable some buttons.
I suggest use new class names, such as rf-ds-f, rf-ds-fr, rf-ds-ff, rf-ds-l.
Should I raise a new features request?
RichFaces v.4.0.0-SNAPSHOT SVN r.17691