4 Replies Latest reply on Jul 20, 2010 12:27 PM by ranjix

    sources for jasper-jdt.jar ?

    ranjix Newbie

      Hi guys, sorry for the bother.

      I did run into an issue with some imports in a jsp file, in the sense that the compilation of the java-generated-servlet complains about a specific package:

       

      An error occurred at line: 14 in the generated java file

      The import com.bluemartini.remotedesktop.itemchooser cannot be resolved

       

      The thing is that the other packages imported work fine, and the specific above package (folder + classes) mentioned in the error is obviously next to the other packages (folders) which seem to work. Tests playing with changing the name of the package and also the folder with the classes worked (I changed the name of the package to ...itemchooser2, changed the name of the folder with the classes the same, and it worked), but as soon as I got back to this particular package name, it failed. It drives me nuts, makes no sense, so I wanted to debug this to see what's going on. The problem is that I can't find the sources for the classes inside jasper-jdt.jar, which seem to be some eclipse related classes. I did download the sources for jboss5.1.0, but none of the jars inside contains the sources for org.eclipse.jdt.... packages.

      Any idea how to get those? Is not really obvious which version of eclipse sources have been used, otherwise I would go to eclipse and download those.

       

      Thanks for any suggestion,

      ranjix