0 Replies Latest reply on Jul 19, 2010 5:18 PM by Unknown Entity

    Weird problems while setting up a HTTP Session Replication in JBoss AS 4.2.3

    Unknown Entity Newbie

      Hi.

       

      We're trying to set up a JBoss AS 4.2.3 cluster consisting of 6 nodes, along with application cache and HTTP session replication enabled. Everything is done according to manual found here:  http://docs.jboss.org/jbossas/docs/Clustering_Guide/beta422/html/clustering-http-app.html.

      The cluster was succesfully built and configured, application cache replication works, but we still cannot overcome the difficulties with session replication. The situation is as follows:

       

      1. We open up the site via load balancer, effectively getting onto one random node.
      2. We try to login, and stay logged in as long as load balancer still keeps us on the same node.
      3. If we are being redirected away, we become not logged in again.
      4. Our login state remains intact on the first node, so after a couple of browser refreshes we stumble on the first site and see ourselves as logged in.

       

      There're no error messages in cluster.log and server.log, but there're some strange information in jmx_console for TomcatClusteringCache:

       

        /JSESSION
      
          /localhost
      
            /ROOT
      
              /xWzyiAOLFHBIozJKG3TPOQ**
      VERSION: 5
      xWzyiAOLFHBIozJKG3TPOQ**: [B@185c9300

       

      The last value ([B@...] is different on each node.

       

      According to manual, this must be a MarshalledValue, but what we got here is some strange garbage.

      Any ideas?