1 Reply Latest reply on Sep 23, 2010 3:47 PM by ranjix

    the sources for jasper-jdt.jar?

    ranjix Newbie

      Hi guys, sorry for the bother.

      I did run into an issue with some imports in a jsp file, in the sense that the compilation of the java-generated-servlet complains about a specific package:


      An error occurred at line: 14 in the generated java file

      The import com.bluemartini.remotedesktop.itemchooser cannot be resolved


      The respective jsp has about 10 imports, from which the above itemchooser is only one. Others:



      import com.bluemartini.remotedesktop.*

      import com.bluemartini.remotedesktop.itemchooser.*

      import com.bluemartini.remotedesktop.htmlapp.*



      Funky, from the above, only itemchooser fails. The classes are obviously next to the other ones (remotedesktop, htmlapp, etc). Even more strange, playing with changing the name of the package and also the folder with the classes worked (I changed the name of the package to ...itemchooser2, changed the name of the folder with the classes the same, and it worked), but as soon as I got back to this particular package name, it failed. It drives me nuts, makes no sense, so I wanted to debug this to see what's going on. The problem is that I can't find the sources for the classes inside jasper-jdt.jar, which seem to be some eclipse related classes. I did download the sources for jboss5.1.0, but none of the jars inside contains the sources for org.eclipse.jdt.... packages.


      Any idea how to get those? I asked already in the Beginner's Corner but no resolution yet. See here - https://community.jboss.org/message/553372#553372 - for what I tried already.


      Thanks for any suggestion,



      P.S. Sorry for the repeat

        • 1. Re: the sources for jasper-jdt.jar?
          ranjix Newbie

          After contacting JBoss support I got the sources.

          After debugging with the respective sources, it became apparent that there is a problem with the package names which seem to be teh same as some class names (case sensitive). Example -


          package a.b.c

          class a.b.C


          If one creates a jsp with an import a.b.c.*, that will fail with the above error (the import a.b.c cannot be resolved). Hope they get to a solution, but, regardless, changing the name of the class or package should resolve the issue (as a workaround, otherwise pretty annoying)