1 Reply Latest reply on Jul 21, 2010 11:43 AM by Philipp Leusmann

    NullPointerException at org.jboss.ws.tools.JavaToXSD.parseSchema

    Philipp Leusmann Newbie

      Hi,

       

      I ama currently trying to deploy a WebApplication using EJB3 Jax-WS in JBoss.

      The Application written using the Eclipse RAP Framework and thus using OSGi (Equinox).

       

      But when the WebServices are setup, I always get the following NullPointerException:

       

      java.lang.NullPointerException
          at org.jboss.ws.tools.JavaToXSD.parseSchema(JavaToXSD.java:178)
          at org.jboss.ws.tools.wsdl.WSDL11Reader.processTypes(WSDL11Reader.java:451)
          at org.jboss.ws.tools.wsdl.WSDL11Reader.processDefinition(WSDL11Reader.java:180)
          at org.jboss.ws.tools.wsdl.WSDLDefinitionsFactory.parse(WSDLDefinitionsFactory.java:129)
          at org.jboss.ws.metadata.umdm.ServiceMetaData.getWsdlDefinitions(ServiceMetaData.java:293)
          at org.jboss.ws.metadata.builder.jaxws.JAXWSClientMetaDataBuilder.buildMetaData(JAXWSClientMetaDataBuilder.java:84)
          at org.jboss.ws.core.jaxws.spi.ServiceDelegateImpl.<init>(ServiceDelegateImpl.java:138)
          at org.jboss.ws.core.jaxws.spi.ProviderImpl.createServiceDelegate(ProviderImpl.java:63)
          at javax.xml.ws.Service.<init>(Service.java:79)

      [...]

       

       

      I did alread look at that piece of code, and found it is trying to resolve a URL like

      file:/var/folders/0W/0WCNl0ONFvm5RkTGZc5t5E+++TI/-Tmp-/JBossWS_de.some.package.name9174384271488964615.xsd

       

      The file actually exists.

       

      Can anybody tell me, what is causing the NPE? I am using JBoss5.1.GA.

       

      Regards,

      Philipp