2 Replies Latest reply on Jul 26, 2010 3:03 AM by Ilya Shaikovsky

    Richfaces OC4J and skins properties

    Bruno Krebs Newbie

      Hello again!

       

      I'm developing an app to be deployed in a OC4J 10.1.3 conteiner and I'm encountering problems to load skin properties. When I say encountering problem I mean they are not loading at all, or at least its look like they aren't. I say that because after a lot of hours struggling to understand why my rich:modalPanel and my rich:calendar were not rendering properly, I figured it out that adding the css of these component on my style.css file (copying from the richfaces source code and pasting it ) solved the problem.

       

      But I'm wondering why on earth I have to do that?! It was working when I deployed my app on a tomcat installation. And I already did the OC4J tricks to properly deploy my app (i.e. removing inherited 'oracle.xml' and 'oracle.xml.security' shared libraries).

       

       

      <context-param>
              <param-name>org.richfaces.SKIN</param-name>
              <param-value>faat</param-value>
          </context-param>

      this is what I have on my web.xml file to load my custom skin (works on tomcat but not on OC4J)...

       

      Any ideas?

       

      Thanks!

        • 1. Re: Richfaces OC4J and skins properties
          Bruno Krebs Newbie

          <context-param>
                  <param-name>org.richfaces.SKIN</param-name>
                  <param-value>faat.skin</param-value>
              </context-param>

          Ok I just tried to add ".skin" at the end to see what happen and an Exception was thrown telling me that the skin file was not found. So I guess it was loading it before but it is something to do with the xcss files...

           

          Just for record I'm almost getting this combination of frameworks to work on a OC4J conteiner.

           

           

          Mojarra (jsf RI) 1.2

          facelets 1.2

          seam 2.2.0 GA

          jpa/hibernate 3.3.1

          richfaces 3.1.6.GA

          now it is just a matter of fixing this annoying richfaces user interface bug...

           

          Any help would be great!

          • 2. Re: Richfaces OC4J and skins properties
            Ilya Shaikovsky Master

            if there are any exceptions in log if just faat defined as skin? Check please also in FireBug NET tab the statuses of resources requests. Check the security configuration, maybe some settings in OCGI prevents the resources from loading?