2 Replies Latest reply on Jul 30, 2010 1:47 AM by Joydeep Sarkar

    Problem with backup server startup

    Joydeep Sarkar Newbie

      Hello All,

       

      When I try to start the backup server(Live-backup pair) I get the follwoing error,

      19:40:41,767 INFO  [EJBContainer] STARTED EJB: com.getty.mm.metadata.indexing.IndexRequestReceiverBean ejbName: IndexRequestReceiverEJB
      19:40:42,579 INFO  [Http11Protocol] Starting Coyote HTTP/1.1 on http-seadcmmjms04%2F10.240.132.216-8080
      19:40:43,452 INFO  [AjpProtocol] Starting Coyote AJP/1.3 on ajp-seadcmmjms04%2F10.240.132.216-8009
      19:40:43,467 INFO  [ServerImpl] JBoss (Microcontainer) [5.1.0.GA (build: SVNTag=JBoss_5_1_0_GA date=200905221053)] Started in 1m:15s:652ms
      19:40:43,472 INFO  [HornetQServerImpl] Activating backup server
      19:40:43,540 INFO  [JournalStorageManager] Using AIO Journal
      19:40:43,552 WARNING [HornetQServerImpl] Security risk! It has been detected that the cluster admin user and password have not been changed from the installation default. Please see the HornetQ user guide, cluster chapter, for instructions on how to do this.
      19:40:45,573 ERROR [HornetQActivation] Unabler to start activation
      HornetQException[errorCode=100 message=Queue jms.queue.indexRequestQueue does not exist]
              at org.hornetq.core.remoting.impl.ChannelImpl.sendBlocking(ChannelImpl.java:280)
              at org.hornetq.core.client.impl.ClientSessionImpl.internalCreateConsumer(ClientSessionImpl.java:1512)
              at org.hornetq.core.client.impl.ClientSessionImpl.createConsumer(ClientSessionImpl.java:444)
              at org.hornetq.core.client.impl.ClientSessionImpl.createConsumer(ClientSessionImpl.java:389)
              at org.hornetq.core.client.impl.DelegatingSession.createConsumer(DelegatingSession.java:194)
              at org.hornetq.ra.inflow.HornetQMessageHandler.setup(HornetQMessageHandler.java:152)
              at org.hornetq.ra.inflow.HornetQActivation.setup(HornetQActivation.java:265)
              at org.hornetq.ra.inflow.HornetQActivation$SetupActivation.run(HornetQActivation.java:475)
              at org.jboss.resource.work.WorkWrapper.execute(WorkWrapper.java:205)
              at org.jboss.util.threadpool.BasicTaskWrapper.run(BasicTaskWrapper.java:260)
              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
              at java.lang.Thread.run(Thread.java:619)
       


      Even though the queue(indexRequestQueue) is configured in hornetq-jms.xml, I keep getting the same message.

       

         <queue name="IndexRequestQueue">
            <entry name="/queue/indexRequestQueue"/>
         </queue>

      Could anyone pelase tell me what I need to do for the same?

       

      TIA,

      Joydeep