6 Replies Latest reply on Aug 20, 2010 8:55 AM by William Anez

    Migration

    William Anez Newbie

      Hi, can anyone point me in the right direction? im trying to migrate a full app running perfectly in JBoss-4.2.3.GA to JBoss 6 and there is a lot of thing I don't know, like a simple MBean service I have, something like:

       

           public interface MyServiceMBean extends ServiceMBean {

       

      And guess what ? there is not a ServiceMBean in jboss 6 libs, I supose things like this one was mention here before, so I need some guiadance.

       

      Thanks in advance.

        • 1. Re: Migration
          Zemian Deng Apprentice

          Hum... so did you see errors when you run your "full" applications under JBoss6?

           

          Your old MBean style services are still supported in JBoss6 and they works still similar the same way. Look for any files ends with *-service.xml under the deploy directly, and they are the same old <mbean> still.

           

          Try run your app in JBoss5 GA release first, and the move onto the JBoss6 as it still in beta. Post back with specific problems you see.

          • 2. Re: Migration
            William Anez Newbie

            Yes, now I'm testing with JBoss 5, I got my ServiceMBean and the project compiles, but when I deploy the service says that one dependency is missing, my jboss-service looks like:

             

            in JBoss 4:

             

            <?xml version="1.0" encoding="UTF-8"?>
            <server>
              <mbean code="com.nexus.jmx.NexusCore"
                        name="nexus:service=NexusCore">
                   <attribute name="Version">Nexus</attribute>
                   <depends>jboss.j2ee:module=nexus-app-server.jar,service=EJB3</depends>
              </mbean>
            </server>

             

            in JBoss 5 as i can see in the JMX Console (localhost:8080/jmx-console)

             

            <?xml version="1.0" encoding="UTF-8"?>
            <server>
              <mbean code="com.nexus.jmx.NexusCore"
                    name="nexus:service=NexusCore">
                   <attribute name="Version">Nexus</attribute>
               <depends>jboss.j2ee:ear=nexus-app-server.ear,jar=nexus-app-server.jar,service=EJB3</depends>
              </mbean>
            </server>
            And when I do the deploy I'm getting:
            08:34:23,920 ERROR [org.jboss.profileservice.bootstrap] Failed to load profile:: org.jboss.deployers.client.spi.IncompleteDeploymentException: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):

             

            DEPLOYMENTS MISSING DEPENDENCIES:
            Deployment "nexus:service=NexusCore" is missing the following dependencies:
            Dependency "jboss.j2ee:ear=nexus-app-server.ear,jar=nexus-app-server.jar,service=EJB3" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.j2ee:ear=nexus-app-server.ear,jar=nexus-app-server.jar,service=EJB3' **")
            Any ideas ?

            • 3. Re: Migration
              Zemian Deng Apprentice

              Looks like  you maybe depends on the wrong objectName. Your <depends> objectName looks like is the actual deployment of the EJB, not the EJB itself. Try to find the EJB in your jmx-console that has "name=<your_ejb_name>" in it, and use that instead.

              • 4. Re: Migration
                William Anez Newbie

                Yes, you were right, it's working now. I really appreciate your help, I'm gonna keep working on this migration and maybe I will ask something related again in the short future, thanks again for helping me out.

                • 5. Re: Migration
                  pratap babar Newbie

                  Hey have you deployed an ejb2 application to jboss5.1 while migration.

                   

                  If yes ,Please tell me what problems you face ?

                  • 6. Re: Migration
                    William Anez Newbie

                    Thanks for posting but no, Im working with EJB3, and the problem on this discussion was fixed by adding the right jar.

                     

                    Thanks again for your interest.