6 Replies Latest reply on Aug 24, 2010 11:55 AM by Karoy Labs

    Deployments and the Console

    Karoy Labs Newbie

      First, a quick bkgrnd:

      I've got Weblogic background and all kinds associated JEE skills, in case that's supposed to make me smarter about things..

      With that, I haven't had much experience with JBoss, nor with JBPM. Practically a noob with both..

       

      But about my current problem..

      JBPM 4.4 downloaded, unzipped. Executed ant demo.setup.jboss, but it croaked during Eclipse download, so I did that manually. After that I ran teardown and setup again, which then completed, but I'm still not sure if everything is in place as they should be.

      By now, HSQL and JBoss start up, so I can access web modeler and Console. Log in with alex but there's nothing to be seen in the console, as in processes, nada. Tried running ant install.examples.into.jboss, but it croaked with "jbpm-4.4\examples\build.xml:120: org.jbpm.api.JbpmException:
        xml validation error: cvc-complex-type.4: Attribute 'method' must appear on element 'java'. [line=8 column=40 ]". I haven't followed up on this yet.

       

      Next, in Eclipse Modeler, I went and created a very simple process and made a .bar file out of the .jpdl.xml and .png files. No Java classes yet, only these two. The process doesn't do anything, simply START=>TASK=>END.

       

      Created a simple build.xml that deploys it, seemingly without error.

       

      I am expecting the deployed process to show up in the Console, ready for execution. Don't really if it would croak, just see it try would do it.

      Reading the User Guide makes me think I need to write a Service class impl and that's the guy that gets recognized by the Console then?

      Obvoiusly, I've got some learning to do, but any guidance to get out of the woods would be appreciated..

       

      Thanks,

      karoy

        • 1. Re: Deployments and the Console
          Alejandro Guizar Master

          Karoy, can you start over, running "ant demo.setup.jboss" only (no other target) and attach file jbpm-4.4/jboss-5.1.0.GA/server/default/log/server.log to your post? That would help diagnose the problem.

          • 2. Re: Deployments and the Console
            Karoy Labs Newbie

            Ok, so I redid the whole thing, after wiping out the whole jbpm 4.4 environment. Kept the jboss and eclipse download zip to cut down a bit on the setup duration. After all this, the examples.bar is listed in Runtime.Deployments, as well the Processes tab shows all processes. Better.

             

            Next, the deployment of my test process, using JbpmDeployTask, completed successfully as before. The ant output shows the deployer talking to HSQL and doing its thing, but I still can't see it in the jBPM console.

             

            So, again, something happened, but not sure what. What's supposed to happen after/during a deployment? I think something was added to the database, but how does that get listed in the jBPM console?

             

            Thanks again!

            karoy

            • 3. Re: Deployments and the Console
              Karoy Labs Newbie

              Ok, so I've figured out that the HSQL settings were pointing to an in-memory instance.

               

              After, updating the HSQL URL settings for my deploy script, the JBPM4_DEPLOYMENT tbl now lists my process only {previously, it had the examples.bar}.

               

              However, now I can't log back into the Console using alex/password. Or mike, or the others.

              • 4. Re: Deployments and the Console
                Karoy Labs Newbie

                More progress: figured out that the deployer wiped out the schema contents, beginning somewhere with this line "INFO: Mapping class: org.jbpm.pvm.internal.identity.impl.UserImpl -> JBPM4_ID_USER" from the deploy ant build logs.

                 

                Easily fixed by re-running the example.identities.sql from the demo setup.

                 

                That done, I can again log in to the Console and see my process.

                But only my process. The examples process is gone. Does this mean 1 process per schema/deploy?

                Need to learn some more on how this whole deployment works, obviously..

                • 5. Re: Deployments and the Console
                  Maciej Swiderski Master

                  Please review your hibernate configuration file, it probably uses create-drop strategy so every time your run your deploy process entire schema is wiped out.

                  Once you modify this, load example identities and all sample processes and you're ready to go.

                  • 6. Re: Deployments and the Console
                    Karoy Labs Newbie

                    Ha! Of course you're right. I copied the Hibernate cfg from the demo without looking at it twice. Thanks!