1 Reply Latest reply on Aug 24, 2010 7:24 AM by Bernd Wengenroth

    Have you got any struts project deploying error in Jboss 6.0.0.M4?

    Rakitha Suranga Newbie

      This is regarding issue id JBAS-8341. I got an advice saying discuss from here.

       

      The brief description is:

       

      Jboss 6.0.0.M4.

       

      I got following error when I run same application in jboss 6.0.0.M4. I didn’t get any issue from jboss 5.1.0.

       

      20:42:15,336 INFO [STDOUT] java.io.FileNotFoundException: vfs:\C:\jboss-6.0.0.20100721-M4\server\default\deploy\Form_Processing_Struts2_Ant.war\WEB-INF\lib\struts2-core-2.1.8.1 (The filename, directory name, or volume label syntax is incorrect)

       

      The "struts2-core-2.1.8.1.jar" file included in correct location. I can confirm that.

       

      Please see issue id JBAS-8341 for complete description.

       

      Thanks

        • 1. Re: Have you got any struts project deploying error in Jboss 6.0.0.M4?
          Bernd Wengenroth Newbie

          I got the same error with Win 7 / JBoss 6.0.0.20100721-M4 / Struts 2.2.1.

          The error occures in the xwork-lib. I also tried different xwork version, same result.

           

          In my case, first time xworks tries to load "struts-default.xml"

           

          xwork gets from struts2 this url:

           

          vfs:/D:/jboss-6.0.0.M4/server/default/deploy/LuZie.ear/WEB.war/WEB-INF/lib/struts2-core-2.2.1.jar/struts-default.xml

           

          Then tries to load it:

           

          URL url = URLUtil.normalizeToFileProtocol(fileUrl);

           

          if (url != null) {
               JarFile jarFile = new JarFile(new File(url.getPath().replaceAll("%20", " ")));
               ZipEntry entry = jarFile.getEntry(fileNameInJar);
               return new JarEntryRevision(jarFileName.toString(), fileNameInJar, entry.getTime());
          }

           

          url is = "vfs:/D:/jboss-6.0.0.M4/server/default/deploy/LuZie.ear/WEB.war/WEB-INF/lib/struts2-core-2.2.1"

           

          This fails!