7 Replies Latest reply on Aug 25, 2010 2:49 PM by Ramki Gollanapalli

    JBoss 4.2.2 is not discovered by RHQ 3 server

    Ramki Gollanapalli Newbie

      Hi

      I am running a RHQ 3 Server and RHQ 3 agent on SunOS Unix. As soon as I install server and agent, I could start both of them with out any issues.

      However, I could not see the RHQ Server , RHQ Agent or other JBoss AS 4.2.2 instances by default..

      Do I have to manually configure anything on either sides to get this discovered?

       

      Any help in this regard will be much appreciated..

       

       

      Please see the attached files for agent and server logs

       

      Thanks in advance

      Ramki

        • 1. Re: JBoss 4.2.2 is not discovered by RHQ 3 server
          mazz Master

          As long as the agent can see the process table and scan it for running JBossAS processes, it should at least find them. I see in your agent logs it can see them. I also see lots of errors in your agent and server logs about misconfigured agents (some agents tried to register under the same name of other agents which is a no-no). I'm not sure what your specific problem is that the auto-discovery queue doesn't show the JBossAS servers, but make sure all your agents are properly configured and are pointing to the RHQ Server you think they are talking to.

           

          From the agent prompt, you can type "sender status" to see what RHQ Server the agent is talking to - make sure it is correct.  Do a "ping" to make sure the agent is talking to it. You can type "inventory" to get a list of resources in the agent's local inventory (to make sure it really found what you think it found - do a "help inventory" for syntax help of all the different options there). An "inventory -f" will send up an inventory report to the server - at which point your auto-discovery queue should have resources that can be committed to inventory.

           

          It might also be helpful to you to enable debug mode in the agent and restart it - see the FAQ on how to enable debug mode in the agent (see info about RHQ_AGENT_DEBUG env var).

           

          Other than that, I really can't tell what's going on.  But since I see lots of errors about agents being denied access in the server log, that tells me the agents you have set up are not fully and correctly configured.

          • 2. Re: JBoss 4.2.2 is not discovered by RHQ 3 server
            Ramki Gollanapalli Newbie

            Thanks a lot John

            To simplify the environment, I am just running the server and agent on one machine. All other agnts were stopped and uninveritied)

            Here are the results of some of my tests:

            > ping
            Pinging...
            Ping results: [Ack: PING]

             

            Ping seems working fine...

            > register
            The agent will now attempt to register itself with the server.
            Regenerating token=[false]
            Waiting 30 seconds...
            The current registration for this agent is: AgentRegistrationResults: [agent-token=iKe2HcyDnxVJDAjMfPGpvWREBEZgCCjVV3xAFJcl5ZEK5+QSw9vYwixyCf5LcVv3IBY=]

            Agent is already registered with server..

             

            When I run the "inventory" command, I could see that RHQ Agent and RHQ Servers are in the agent's inventory list..

            + Resource[id=10008, type=RHQ Agent, key=RHQ Agent, name=RHQ Agent, parent=devnasv009, version=3.0.0] (sync=SYNCHRONIZED, state=STOPPED, avail=UNKNOWN, sched=0/0)
               + Resource[id=10009, type=JBossAS Server, key=/local/jboss_runtime/jopr3/rhq-server-3.0.0/jbossas/server/default, name=devnasv009 RHQ Server, parent=devnasv009, version=4.2.3.GA] (sync=SYNCHRONIZED, state=STOPPED, avail=UNKNOWN, sched=0/0)

            But I still could not see the Agent and Server in the Server GUI as resources...

            I also could not see the other JBoss AS 4.2.2 servers running on the same machine...

            I clould also see that some other resources were not recognized.. That could be because, I am running the agent with my own ID and on some of the file systems, I don't have access.

             

            Any idea why I have trouble discovering RHQ process resources on the server UI and other JBoss AS servers??

             

            Any help in this regard will be highly appreciated..

            Thank you

            Ramki

            • 3. Re: JBoss 4.2.2 is not discovered by RHQ 3 server
              mazz Master

              > sync=SYNCHRONIZED, state=STOPPED, avail=UNKNOWN

               

              This means the server and agent are synchronized with respect to those resources but they are not yet committed into inventory.  I suspect you haven't imported them into inventory via the Auto Discovery Queue GUI page. Go to the Dashboard and what do you see in the Auto Discovery  Portlet? There should be a platform with child resources underneath showing you the servers - you need to select those and import into inventory.

               

              If you do not see this - if you see an empty auto-discovery portlet in the dashboard, then there must be some error getting logged in the server log indicating some problem reading the data out of the database. If you log into your database using a normal SQL client (or you can log into http://localhost:7080/admin/test/sql.jsp which is a built in SQL client) and invoke this SQL "select * from RHQ_RESOURCE" you should see your resources in there with NEW inventory status.

              • 4. Re: JBoss 4.2.2 is not discovered by RHQ 3 server
                Ramki Gollanapalli Newbie

                Thanks John for your quick reply..

                I have already run "Auto Discovery Queue" and imported the platform.

                I could see the platform and some of the resources like CPU, File System, Network Adapters under that plotform..

                 

                 

                I ran the command in the database..

                Surprisingly, I do see the RHQ Server record in the table..

                1000810026d694efe3-9392-4ced-a013-6a6daae5d409RHQ AgentRHQ Agent10001NEWFALSERHQ Management Agent
                1000910050eddb5422-99a6-4de3-9bf1-7ae07f0e71dbdevnasv009 RHQ Server/local/jboss_runtime/jopr3/rhq-server-3.0.0/jbossas/server/default10001NEWFALSEJBoss Application Server hosting the RHQ Server

                Just for your reference, I am attaching the logs..

                Thanks in advance.. any help to resolve this issue will me much appreciated..

                 

                Ramki

                 

                Message was edited by: Ramki Gollanapalli

                • 5. Re: JBoss 4.2.2 is not discovered by RHQ 3 server
                  mazz Master

                  Do you see that column "inventory_status"? Their values are "NEW" in your SQL output. This means they were not committed to inventory. If they were, that column would have a value of "COMMITTED". This means somehow you still didn't commit these resources into inventory properly. I don't know what to say other than to ask - when you go to the dashboard, what do you see exactly in the Auto-Discovery Queue portlet? If you click the "View All" button found in that portlet, you will go to the AutoDiscovery Queue page - what do you see in there if you view "Both New And Ignored" resources?

                  • 6. Re: JBoss 4.2.2 is not discovered by RHQ 3 server
                    Ramki Gollanapalli Newbie

                    Hi John, Thanks again for your quick replies..

                     

                    As far as Auto Discovery goes, Yes, I do see "Both new and Ignored" in the dropdown list got selected....

                    I have imported once again. Import is successful. But no luck in discovering the Server, Agent or other JBoss AS resources.. I also see couple of "JMX Server" entries with the same status..

                     

                    Just FYI.. I am using JOPR 3

                    I also have couple of JBoss 4.2.2, 5.1 instances already running on the same host hosting different applications...

                    I don't see the JBoss 4.2.2, 5.1 instances in the RHQ_RESOURCE table.. at least with NEW status also..

                     

                    Thanks a lot for your time in replying to this ticket.

                    Ramki

                    • 7. Re: JBoss 4.2.2 is not discovered by RHQ 3 server
                      Ramki Gollanapalli Newbie

                      Hi John

                      Good news is that after I started RHQ Server and Agent with Java 1.6, I could see the Server, Agent processes in JOPR UI.

                      However, I see some JMX Server processes in the UI. I am suspecting that these could be the JBoss Servers we have on the host.

                      The reason could be, we create a very long string to start the JBoss Servers as a command line.

                      We don't use the default run.sh or any other scripts.

                       

                      Few more questions:

                      1) Is there any way to see the command line started JBoss instances as JBoss Servers in JOPR UI?

                       

                      2) Is it possible to find the PID of the JMX Server entries in JOPR UI?

                       

                       

                      Any help in this regard is much appreciated.

                      Thanks

                      Ramki