3 Replies Latest reply on May 19, 2009 9:53 AM by Pieter Bosman

    tabPanel - Strange absence of rendering?

    Pieter Bosman Newbie

      Hello all,

      I got a bit of a weird thing going on with my tabPanel I wish to use. It's not rendered as a tabpanel, but rather as a regular set of text and no 'clicking' works.

      I'm able to get both rich & ajax components to work on other pages within the same website, so I'm pretty sure my web.xml and faces-config.xml are correctly configured. So I'm kinda hoping I'm doing something wrong within the creation of my tabPanel.

      Any and all help appreciated!

      Here's the code of my .jsp page

      <%@ page language="java" contentType="text/html; charset=ISO-8859-1"
       pageEncoding="ISO-8859-1"%>
      <%@ taglib prefix="f" uri="http://java.sun.com/jsf/core"%>
      <%@ taglib prefix="h" uri="http://java.sun.com/jsf/html"%>
      <%@ taglib uri="http://richfaces.org/a4j" prefix="a4j"%>
      <%@ taglib uri="http://richfaces.org/rich" prefix="rich"%>
      <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
      <html>
      <head>
      <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
      <title>Tab Test</title>
      </head>
      <body>
      <f:view>
       <rich:tabPanel id="mainTab" switchType="ajax">
       <rich:tab label="Tab1">
       test
       </rich:tab>
       <rich:tab label="Tab2">
       test
       </rich:tab>
       </rich:tabPanel>
      </f:view>
      </body>
      </html>
      


      Thanks in advance!
      Pieter