4 Replies Latest reply on Mar 19, 2011 1:25 AM by KLN Inc

    jboss AS 64 bit Windows xp - installation steps, tips, pitfalls - has anyone installed this in this environment?

    Steve Kohler Newbie

      Hi All,

       

      Has anyone ever set up jboss AS in a Windows 64 bit xp environment before?  I've previously installed AS 4.x and AS 5.x in Windows 32 bit xp, and 32 and 64 bit Redhat linux and done development using jboss/seam, but there seems to be something that I'm missing when trying to get this to run on 64 bit Windows XP.  Anyone know of a list of gotchas or special settings/steps that need to be done because of the 64 bit environment?

       

      I've done the obvious:

      • clean, running install of jdk 6,
      • unzip download from jboss,
      • check to make sure that jbossws-native-saaj.jar, jbossws-native-jaxrpc.jar, jbossws-native-jaxws.jar, and jbossws-native-jaxws-ext.jar are all in the right places. 
      • set JAVA_HOME
      • set JBOSS_HOME
      • put path to java and jboss bin in PATH

       

      Every time I use run.bat with or without a service, the server fails to start correctly while spewing out several errors such as:

       

      "org.jboss.deployers.spi.DeploymentException: Error deploying: file:/C:/jboss-5.1.0.GA/server/default/conf/bootstrap/vfs.xml
          at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)" 

       

      "17:25:59,870 DEBUG [SARDeployer] Error during deploy: vfsfile:/C:/jboss-5.1.0.GA/server/default/conf/jboss-service.xml
      org.jboss.deployers.spi.DeploymentException: Error creating managed object for vfsfile:/C:/jboss-5.1.0.GA/server/default/conf/jboss-service.xml
          at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)"

       

      Any help anyone can offer would be greatly appreciated.  I've got 2 days into this now and it was just supposed to be something I was going to use to make a quick online reference catalog for some work stuff using mysql and java/jboss/seam.

       

      MySQL works fine, so does eclipse (haven't tried to run jboss thru it yet), but jboss, usually an easy install is not running after unzipping.  I've tried 4.2, 5.1, and even the latest 6.0 AS downloads along with fooling around with parameters inside the profile.xml file in the bootstrap folder.  Can't even get the minimal server to run.  Am I missing something obvious?  I've attached the boot.log file if anyone is interested.

       

      Thanks all for your time