8 Replies Latest reply on Sep 13, 2010 4:08 AM by Gary Brown

    Issues in the generated ws-bpel

    glaucus augustus Newbie

      Hi,

       

      I've generated the ws-bpel from the PurchaseGoods.cdm to try executing on Apache ODE, but the generated files have a lot of errors

       

      I'm trying to figure out this errors, but I don't get anything

       

      It has erros like:


      The part 'content' has an invalid value 'BuyRequest' defined for its type. Type declarations must refer to valid values defined in a schema.    PurchaseGoodsProcess_Store.wsdl    /PurchaseGoodsProcess-Buyer/bpelContent    line 12    WSDL Problem

       

      with

       

      PurchaseGoodsProcess_Store.wsdl

      ...

      <wsdl:message name="buyRequest">
          <wsdl:part name="content" type="sto:BuyRequest">
          </wsdl:part>
        </wsdl:message>

      ...

       

      and

       

      store.xsd

      ...

      <element name="BuyRequest" type="tns:StoreType"></element>
          <element name="BuyConfirmed" type="tns:StoreType"></element>
          <element name="BuyFailed" type="tns:StoreType"></element>

       

          <complexType name="StoreType">
              <attribute name="id" type="string"></attribute>
          </complexType>

      ...

       

      I follow all the steps on the savara getting started (all the modifications in the imported project). The purchasing project(used to generate the others) has no errors

       

      I need to deal with the errors and try to fix them or seems like something went wrong in the process?

       

      Thank you

        • 1. Re: Issues in the generated ws-bpel
          Gary Brown Master

          Did you use savara-1.0.0-Final? Its just I tried to generate the BPEL for the Buyer participant (which is the one I think you are referring to from the error message), and I only got two issues related to the bpel, not the wsdl.

           

          The other point is that the Buyer is the client, so this would not actually be able to be deployed as a BPEL process, as there is not inbound message to trigger the process.

           

          I should really detect this and not provide it as an option for generation - I'll create a jira for this issue.

          • 2. Re: Issues in the generated ws-bpel
            glaucus augustus Newbie

            I'm using the final version.

             

            The generation of the buyer files was my fault.

             

            Generating the ws-bpel for the store and the credit angency give the two erros you've mentioned.

             

            Following the getting started, and making the changes it provides for this example, we get the errors I've told you before.

             

            Errors like:

             

            Description    Resource    Path    Location    Type
            Variable "buyConfirmedVar" does not have a part named "BuyConfirmed" - check expression segment "$buyConfirmedVar.BuyConfirmed"    PurchaseGoodsProcess_Store.bpel    /PurchaseGoodsProcess-Store/bpelContent    line 30    BPEL Validation Marker

             

            With this errors, ODE (I guess RiftSaw too) can't deploy the artifacts.

             

            Do you get these errors too?

            It would be better if I send you the project?

             

            Thank you

            • 3. Re: Issues in the generated ws-bpel
              glaucus augustus Newbie

              Forget all of this. It was an Eclipse's joke!

               

              After spending a couple of hours verifying the files, I got the idea to just restart the Eclipse, and yes, all the errors disappeared.

               

              But, the generated bpel for the store and the credit agency still not deploying in ODE(I guess RiftSaw too).

               

              Do you have deployed and executed the generated bpel? those from the savara getting started?

               

              I'm this kind of persistent because I have had errors at each step, making difficult to enacting one choreography.

               

              Thank you a lot

              • 4. Re: Issues in the generated ws-bpel
                Gary Brown Master

                Hi

                 

                The example written up in the Getting Started Guide works when deployed. Probably best if you could attach the BPEL deployment unit (jar) that is failing, so that I can see what is wrong, and whether the artifacts generated by Savara, or the documentation, are causing the problem?

                 

                Regards

                Gary

                • 5. Re: Issues in the generated ws-bpel
                  glaucus augustus Newbie

                  Hi Gary

                  I've been working on this, without success

                  I'm sending the 2 projects generated from the purchase

                  I did the fixes indicated in the guide

                  It would be a problem for you to send the example that is running in your machine? are you using ode or riftsaw?

                  thank you in advance

                  • 6. Re: Issues in the generated ws-bpel
                    Gary Brown Master

                    Hi,

                     

                    Sorry I was going to write back to you yesterday about this, but got sidetracked. After you mentioned about having problems I tried it out and also had errors.

                     

                    Originally when I put the example together, the BPEL editor was not available, so the validation now possible with the editor wasn't being performed - and not sure if the ODE engine is more forgiving.

                     

                    However due to the errors in the editor validation, I have updated the documentation and also included the 'completed' versions of the store and creditagency (bpel and deployment descriptor) in the samples folder. You can download the distribution with the docs/samples from: http://hudson.jboss.org/hudson/job/savara/lastSuccessfulBuild/artifact/sources/distribution/target/savara-1.1.0-SNAPSHOT.zip

                     

                    So you will then just need to generate the BPEL projects as before, but can then copy the completed files in place of the generated ones, which should then hopefully just deploy and run,

                     

                    Regards

                    Gary

                    • 7. Re: Issues in the generated ws-bpel
                      glaucus augustus Newbie

                      Hi Gary, thank you for the files!

                       

                      Unfortunatelly did not work, it still does not deploying in ode. The strangest thing is that it compiles just fine with the bpelc.

                       

                      Are you using riftsaw? The example deploy and run fine at ths environment?

                       

                      I've seen other thing

                       

                      At the wsdl I change it:

                      <soap:address location="http://localhost:8080/StoreService"/>

                      for

                      <soap:address location="http://localhost:8080/ode/processes/StoreService"/>

                       

                      Although it still doesn't deploying, the change makes sense?

                       

                      Thank you

                      • 8. Re: Issues in the generated ws-bpel
                        Gary Brown Master

                        Hi

                         

                        Sorry that it is still not working - but I have had it deploying to RiftSaw and running.

                         

                        Could you attach the jar files that you have deployed to riftsaw so that I can inspect the contents and try them out?

                         

                        In terms of the soap:address location change, that should be fine if deploying to ODE in tomcat.

                         

                        Regards

                        Gary