2 Replies Latest reply on Jun 19, 2012 8:02 AM by Raul Luna

    Application hangs in IE7

    Jesper Vrelits Newbie

      Hi.

      Have a Richfaces application almost ready for production. We have a problem, however, in IE7 where the application "hangs".

       

      The problem is only periodic, it only happens in IE and not firefox. Some user don't have the issue, others have.

       

      IE looks totally up but it is possible to hit enter in the address line. This will make the application to continue.

       

      I reminds a lot about the issue reported here:

       

      http://seamframework.org/Community/SystemHangsIntermediately

       

      We've tried to set org.richfaces.LoadScriptStrategy to DEFAULT but the problem still persists.

       

      Any help or hints to the cause of the problem will be highly appreciated.

       

      Toolset:

       

      JSF 1.2 RI

      Richfaces 3.3.3

      Windows XP

      IE 7

        • 1. Re: Application hangs in IE7
          Jesper Vrelits Newbie

          Just for reference:

           

          Made this fix:

           

          File framework.pack.js.

           

          Change:

           

          document.write("<script id=__onDOMContentLoaded defer src=//:><\/script>");

           

          to:

           

          document.write("<script id=__onDOMContentLoaded  defer src=''><\/script>");

           

          and the problem went away.

           

          You might consider including this in Richfaces 4.

          • 2. Re: Application hangs in IE7
            Raul Luna Newbie

            This change couldn't be correct. First, because you have inserted a quote (") in the middle of a string and thus you are breaking the string. This will end in a sintax error.

             

            However, I've tried to fix make this change:

             

            document.write("<script id=__onDOMContentLoaded  defer src=\''><\/script>");

             

            but this doesnt work: it throws an error in the internet explorer.

             

            I've also tried this:

             

            else{document.write("<script id=__onDOMContentLoaded defer><\/script>");

             

            (removing completely the "src=\\:") which seems to be wrong. I've tested it and it doesnt work though.