0 Replies Latest reply on Sep 3, 2010 11:32 AM by Its Me

    javax.naming.NameNotFoundException  .. <bean> not found

    Its Me Newbie

      Howdy out there,

       

      I'm attempting to install/configure/run the Apache DayTrader (https://cwiki.apache.org/GMOxDOC10/day-trader.html) on multiple App Servers ( WebSphere, JBoss, Weblogic/Oracle, Glassfish).

       

      Following the instructions, no problems getting this application up and running on all app. servers except JBoss.

      The problem I am running into is that for the EJB3 test, it does not find the TradeSLSBean JNDI reference ( whether or not

      I select "use local" ).  However, if I select the Direct test it, it works like a charm.  So I'm struggling to understand why

      this is not working specifically for the EJB3 test.

       

      My JBoss environment is :

           Red Hat 5.5 64-bit

           Sun JDK 1.6 64bit

           JBoss 5.0.1

       

      The error is the typical "not bound" message :

      10:08:27,402 ERROR [Log] Error: TradeAction:createTrade - Lookup of TradeSLSBLocal failed!!!
      10:08:27,402 ERROR [Log] Error: TradeAction:TradeAction() Creation of Trade EJB 3 failed
      javax.naming.NameNotFoundException: TradeSLSBBean not bound
      10:08:27,402 ERROR [STDERR] javax.naming.NameNotFoundException: TradeSLSBBean not bound
      10:08:27,403 ERROR [STDERR]     at org.jnp.server.NamingServer.getBinding(NamingServer.java:771)
      10:08:27,403 ERROR [STDERR]     at org.jnp.server.NamingServer.getBinding(NamingServer.java:779)
      10:08:27,403 ERROR [STDERR]     at org.jnp.server.NamingServer.getObject(NamingServer.java:785)

      ....

      ....

       

      If I go to the JMX consle, select "service=JNDIView" , for the "list" row, select "Invoke" button,

      I can clearly see that the TradeSLSBBean is being registered.

       

      org.jboss.jmx.adaptor.rmi.RMIAdaptorExt)
        |   +- rmi (class: org.jnp.interfaces.NamingContext)
        |   |   +- RMIAdaptor[link -> jmx/invoker/RMIAdaptor] (class: javax.naming.LinkRef)
        +- daytrader-ear-2.1.3-JBoss5 (class: org.jnp.interfaces.NamingContext)
        |   +- TradeSLSBBean (class: org.jnp.interfaces.NamingContext)
        |   |   +- local-org.apache.geronimo.samples.daytrader.ejb3.TradeSLSBLocal (class: Proxy for: org.apache.geronimo.samples.daytrader.ejb3.TradeSLSBLocal)
        |   |   +- local (class: Proxy for: org.apache.geronimo.samples.daytrader.ejb3.TradeSLSBLocal)
        |   |   +- remote-org.apache.geronimo.samples.daytrader.ejb3.TradeSLSBRemote (class: Proxy for: org.apache.geronimo.samples.daytrader.ejb3.TradeSLSBRemote)
        |   |   +- remote (class: Proxy for: org.apache.geronimo.samples.daytrader.ejb3.TradeSLSBRemote)

        |   +- DirectSLSBBean (class: org.jnp.interfaces.NamingContext)
        |   |   +- local (class: Proxy for: org.apache.geronimo.samples.daytrader.ejb3.DirectSLSBLocal)
        |   |   +- remote-org.apache.geronimo.samples.daytrader.ejb3.DirectSLSBRemote (class: Proxy for: org.apache.geronimo.samples.daytrader.ejb3.DirectSLSBRemote)
        |   |   +- local-org.apache.geronimo.samples.daytrader.ejb3.DirectSLSBLocal (class: Proxy for: org.apache.geronimo.samples.daytrader.ejb3.DirectSLSBLocal)
        |   |   +- remote (class: Proxy for: org.apache.geronimo.samples.daytrader.ejb3.DirectSLSBRemote)
        +- JAXR (class: org.apache.ws.scout.registry.ConnectionFactoryImpl)
        +- ProxyFactory (class: org.jnp.interfaces.NamingContext)
        |   +- daytrader-ear-2.1.3-JBoss5 (class: org.jnp.interfaces.NamingContext)
        |   |   +- TradeSLSBBean (class: org.jnp.interfaces.NamingContext)
        |   |   |   +- daytrader-ear-2.1.3-JBoss5 (class: org.jnp.interfaces.NamingContext)
        |   |   |   |   +- TradeSLSBBean (class: org.jnp.interfaces.NamingContext)
        |   |   |   |   |   +- remote (proxy: $Proxy181 implements interface

      Since this is works in Direct mode, that says that its being registered and is working.

       

      Any thoughts about why this would not work in EJB mode ?

       

      Including log file ( no errors )