8 Replies Latest reply on Mar 22, 2011 1:01 PM by Emily Brand

    JBPAPP build failure

    Alexis Hassler Apprentice

      Hi all,

       

      I tried to build JBossAS from JBPAPP_5_0_1_GA tag.

      It failed with this message :

       

      [ERROR] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Compilation failure


      /home/alexis/sewatechnew/Projets/jboss-as/JBPAPP_5_0_1_GA/system-jmx/src/main/org/jboss/system/server/jmx/JMXKernel.java:[46,32] package org.jboss.classloader.spi does not exist


      /home/alexis/sewatechnew/Projets/jboss-as/JBPAPP_5_0_1_GA/system-jmx/src/main/org/jboss/system/server/jmx/JMXKernel.java:[536,6] cannot find symbol
      symbol  : class ClassLoaderSystem
      location: class org.jboss.system.server.jmx.JMXKernel


      /home/alexis/sewatechnew/Projets/jboss-as/JBPAPP_5_0_1_GA/system-jmx/src/main/org/jboss/system/server/jmx/JMXKernel.java:[536,33] cannot find symbol
      symbol  : variable ClassLoaderSystem
      location: class org.jboss.system.server.jmx.JMXKernel


      /home/alexis/sewatechnew/Projets/jboss-as/JBPAPP_5_0_1_GA/system-jmx/src/main/org/jboss/system/server/jmx/JMXKernel.java:[548,36] cannot access org.jboss.classloader.spi.ClassLoaderPolicy
      class file for org.jboss.classloader.spi.ClassLoaderPolicy not found
            VFSClassLoaderPolicy policy = new VFSClassLoaderPolicy(files);

       

      Does it come from a missing dependency or something else ?

        • 1. JBPAPP build failure
          Emily Brand Newbie

          Did you figure out the reason for this error? I'm getting the same one.

           

          Thanks!

          • 2. JBPAPP build failure
            Alexis Hassler Apprentice

            Hi Emily,

             

            Unfortunately, I have no solution. In fact, I gave away.

            The good news is that the build process has been enhanced and is much simpler in JBoss AS 6 and 7.

             

            If you find the solution, I'd apreciate to hear about it.

            • 3. JBPAPP build failure
              Emily Brand Newbie

              The ant build script in the build folder works beautifully. I think the first problem is that we should've been doing mvn clean install in the build directory not the jboss-as directory.

               

              However, when I do run the maven script in the build directory I get the following errors:

              ----------

              12 required artifacts are missing.

               

               

              for artifact:

                org.jboss.jbossas:jboss-as-build:pom:5.1.0-SNAPSHOT

               

               

              from the specified remote repositories:

                central (http://repo1.maven.org/maven2),

                prod-repository.jboss.org (http://repository.jboss.org/maven2-brew),

                repository.jboss.org (http://repository.jboss.org/maven2),

                snapshots.jboss.org (http://snapshots.jboss.org/maven2)

               

               

              When I looked to see if it was my internet connection the artifacts are actually missing from those repositories so I'm not sure if maven works at all as a build script for JBoss EAP 5.0.1

              • 4. JBPAPP build failure
                Alexis Hassler Apprentice

                You're probably right. Maven pom.xml files seem to be here as par of the Ant build, not for pure maven builds.

                • 5. JBPAPP build failure
                  Emily Brand Newbie

                  I did find the solution to the problem though. The version in the pom.xml file should be 5.1.0.GA not 5.1.0-SNAPSHOT. If you change that version in all of the poms you will be able to run maven without a problem. I also added the following to the pom.xml in the jboss-as directory just in case:

                   

                      <repository>

                        <id>jboss-public-repository-group</id>

                        <name>JBoss Public Repository Group</name>

                        <url>http://repository.jboss.org/nexus/content/groups/public</url>

                        <releases>

                          <enabled>true</enabled>

                        </releases>

                        <snapshots>

                          <enabled>false</enabled>

                        </snapshots>

                      </repository>

                      <repository>

                        <id>jboss-deprecated</id>

                        <name>JBoss Deprecated</name>

                        <url>https://repository.jboss.org/nexus/content/repositories/deprecated</url>

                        <releases>

                          <enabled>true</enabled>

                        </releases>

                        <snapshots>

                          <enabled>false</enabled>

                        </snapshots>

                      </repository>

                      <repository>

                        <id>jboss-nexus-repository</id>

                        <name>JBoss Nexus Repository</name>

                        <url>https://repository.jboss.org/nexus</url>

                        <releases>

                          <enabled>true</enabled>

                        </releases>

                        <snapshots>

                          <enabled>false</enabled>

                        </snapshots>

                      </repository>

                  • 6. JBPAPP build failure
                    Alexis Hassler Apprentice

                    Unfortunatly, it does not work for me. Where do you launch your "mvn install" from ?

                     

                    When I launch it from the build directory, it does not find org.jboss.system:system-jmx:jar:5.1.0.GA and fron root directory, maven complains about some missing versions on some dependencies.

                    • 7. JBPAPP build failure
                      Emily Brand Newbie

                      I only tested it in the jboss-as/jbossas directory. You might need to do mvn clean install in each module instead of in the entire jboss-as directory. Let me know how that goes.

                      • 8. JBPAPP build failure
                        Emily Brand Newbie

                        I found the underlying error:

                         

                        Open <SOURCE FOLDER HOME>/jboss-as/system-jmx/pom.xml. Add the following into the <dependencies>...</dependencies>

                          <dependency>

                              <groupId>org.jboss.cl</groupId>

                              <artifactId>jboss-classloader</artifactId>

                            </dependency>

                         

                        Open <SOURCE FOLDER HOME>/jboss-as/ejb3/pom.xml. Add the following into the <dependencies>...</dependencies>

                          <dependency>

                              <groupId>org.jboss.ejb3</groupId>

                              <artifactId>jboss-ejb3-endpoint-deployer</artifactId>

                          </dependency>

                         

                        Also change 5.1.0-SNAPSHOT in <version> tags of all of the poms (jboss-as and sub-folders) to 5.1.0.GA