7 Replies Latest reply on Sep 23, 2010 1:32 PM by Erik-Berndt Scheper

    Proposal to rename ValidAuditTimeStrategy

    Erik-Berndt Scheper Newbie



      I have been thinking about this some time, but I believe we need a better name for the ValidAuditTimeStrategy.

      Of course, this affects both the class name and the envers configuration option.


      I think we need to do this ASAP (before 3.6.0 goes CR or even GA), because it will cause less incompatibility issues.

      We could keep the old configuration option for compatibility reasons, but that may not be necessary since you marked this as experimental.


      There are a couple of reasons why I dislike this name

      * It suggests that AuditTimes can be invalid. I cannot image how this could be the case.

      * We already have AuditStrategy and DefaultAuditStrategy. So it would we logical that the name should end with AuditStrategy.

      * The strategy is based on the use of a revision end column, not on anything like time(stamp)s.



      I propose to rename this strategy to RevisionEndColumnAuditStratigy.



      What do you think? If you agree, I could create an issue with a patch to fix this.



      Kind regards,

      Erik-Berndt Scheper



      BTW Could you take a look at my revised patch for HHH-5371?

      If this could be integrated before I create a patch to rename the audit strategy, than that would spare me the time to revise the patch for HHH-5371 again.