1 Reply Latest reply on Sep 14, 2010 11:54 AM by Brian Stansberry

    <nic name="eth1">

    Kabir Khan Master

      I get problems starting up the current master (I'm on OS X):

       

      11:53:35,758 ERROR [server] Service [service jboss.network.external] start failed: org.jboss.msc.service.StartException in service service jboss.network.external: failed to resolve interface for external, <unknown-TODO> line 80, column 36
      at org.jboss.as.services.net.NetworkInterfaceService.start(NetworkInterfaceService.java:70)
      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1001)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_20]
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_20]
      at java.lang.Thread.run(Thread.java:637) [:1.6.0_20]

      11:53:35,758 ERROR [server] Service [service jboss.network.external] start failed: org.jboss.msc.service.StartException in service service jboss.network.external: failed to resolve interface for external, <unknown-TODO> line 80, column 36

      at org.jboss.as.services.net.NetworkInterfaceService.start(NetworkInterfaceService.java:70)

      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1001)

      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_20]

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_20]

      at java.lang.Thread.run(Thread.java:637) [:1.6.0_20]

      This is due to the following in domain.xml:
             <interface name="external">
                  <!-- 
                      Here we name the NIC; the IP address associated with NIC whose
                      byte representation has the lowest
                  -->
                  <nic name="eth1"/>
              </interface>
      If I change that to
             <interface name="external">
                  <!-- 
                      Here we name the NIC; the IP address associated with NIC whose
                      byte representation has the lowest
                  -->
                  <!-- nic name="eth1"/ -->
                  <inet-address value="127.0.0.1"/>
              </interface>
      it starts fine. Not sure if I need to add a NIC alias or something like that (or how to do that if that is the case). This is my setup:
      $ifconfig
      lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
      inet6 ::1 prefixlen 128
      inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
      inet 127.0.0.1 netmask 0xff000000
      gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
      stf0: flags=0<> mtu 1280
      en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
      ether 00:1e:c2:1c:42:41
      media: autoselect
      status: inactive
      en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
      ether 00:1e:c2:bc:4f:91
      inet6 fe80::21e:c2ff:febc:4f91%en1 prefixlen 64 scopeid 0x5
      inet 192.168.1.69 netmask 0xffffff00 broadcast 192.168.1.255
      media: <unknown subtype>
      status: active
      fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078
      lladdr 00:1f:5b:ff:fe:28:9c:f2
      media: autoselect <full-duplex>
      status: inactive
      vnic0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
      ether 00:1c:42:00:00:08
      inet 10.211.55.2 netmask 0xffffff00 broadcast 10.211.55.255
      media: autoselect
      status: active
      vnic1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
      ether 00:1c:42:00:00:09
      inet 10.37.129.2 netmask 0xffffff00 broadcast 10.37.129.255
      media: autoselect
      status: active
      utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1280
      inet 10.36.7.86 --> 10.36.7.86 netmask 0xfffffc00