2 Replies Latest reply on Sep 16, 2010 2:35 PM by saket kumar

    JBoss 4.2.3 GA - Web Console - JVM Environment issue

    saket kumar Newbie

      HI,

       

      Our JBoss 4.2.3 GA was running on 32 bit Java 6 environment, and as we have to support a multi threaded functionality we need to run the JBoss in 64 bit Java environment.

       

      Hence I am trying with the following JVM options, to achieve optimal performance with garbage collection.

       

      JVM options " -d64 -Xms6g -Xmx6g -XX:ThreadStackSize=256 -XX:+UseParallelGC -XX:MaxPermSize=512m -XX:NewRatio=3 "

       

      However when I monitor in JBoss WEB-CONSOLE page I can see the  maximum and minimum memory  of  5GB  where as it should have been 6 GB.

       

      If I specify 3GB it correctly shows 3GB, when I specify more than 3GB, it always shows 1GB less.

       

      Please let me know why it is showing 1GB less? See the screen shot below for details.

       

      JVM - Hardware

      Hardware

      #CPU: 7

      OS: SunOS 5.10 (sparcv9)

      JVM Environment

      Free Memory: 3 GB

      Max Memory: 5 GB

      Total Memory: 5 GB

      #Threads: 104

      JVM Version: 17.0-b16 (Sun Microsystems Inc.)

      JVM Name: Java HotSpot(TM) 64-Bit Server VM

       

      Regards,

      Saket

        • 1. Re: JBoss 4.2.3 GA - Web Console - JVM Environment issue
          Peter Johnson Master

          Is this screen shot from the Web Console?

           

          If you add -verbose:gc to your command line, and look at the data printed out by that option, what does it give for the heap size (if you can't tell, just post one or two lines of the output).

           

          By the way, you do not need to use a 64-bit JVM just to support multi-thread, 32-bit also supports it. And I hope that this setting is a typo: -XX:ThreadStackSize=256. 256 bytes is a rather small stack size!

          1 of 1 people found this helpful
          • 2. Re: JBoss 4.2.3 GA - Web Console - JVM Environment issue
            saket kumar Newbie

            HI Peter.

            Thanks for the reply

             

            I increased the -XXThreadStackSize=256m and made the -XX:NewRatio=2 now i am able to get the reasonably good performance.

            Too many minor collections were happening with -XX:NewRatio=3 and major collection were taking longer time to complete  due to increased size of the  tenured segment.i am still testing this, ill update you on my findings.

            Regards