0 Replies Latest reply on Sep 30, 2010 8:06 PM by code Nombre

    How to use app's version of Hibernate i.e. Hibernate 3.5.6 instead of one shipped with JBOSS 5.0.1

    code Nombre Newbie
      Hello there,


      I am trying to get my  app  running on JBOSS 5.0.1_GA. My app internally uses Hibernate 3.5.6   suite. And I know JBoss 5.0 uses somewhat older version. As a result I   get NoClassDefinitionFound Errors during JBOSS Boot time. Is   there a way I can tell JBOSS to use my Version of Hibernate inside my   app? In otherwords is it possible to override the version of Hibernate   used by JBOSS 5 somehow?
      I  tried tweeking both the Web Container and EAR container level   classloaders to use the JAR's that are packaged with WAR or EAR but to   no avail.


      Here is some snippets from both Jboss-web.xml and Jboss-app.xml respectively for JBOSS 5:


      <?xml version="1.0" encoding="UTF-8"?>
      <!DOCTYPE jboss-web PUBLIC "-//JBoss//DTD Web Application 5.0//EN"


      <?xml version="1.0"?>
      <!DOCTYPE jboss-app PUBLIC "-//JBoss//DTD J2EE Application 1.4//EN"