2 Replies Latest reply on Dec 7, 2010 3:53 AM by Jean-Frederic Clere

    as6 m5 jasper exception: null

    brian long Newbie

      this is deployed as an EAR that deploys and runs fine in as5.  also, it's not a generic jsp issue because other WARs containing jsps run just fine.

       

      2010-10-01 11:00:11,150 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/dat].[jsp]] (http-elvis.middleware.vt.edu%2F128.173.13.100-8443-1) Servlet.service() for servlet jsp threw exception: org.apache.jasper.JasperException: /layouts/mainLayout.jsp(1,1) /layouts/tiles.header.jsp(1,1) null
          at org.apache.jasper.compiler.DefaultErrorHandler.jspError(DefaultErrorHandler.java:40) [:6.0.0.20100911-M5]
          at org.apache.jasper.compiler.ErrorDispatcher.dispatch(ErrorDispatcher.java:407) [:6.0.0.20100911-M5]
          at org.apache.jasper.compiler.ErrorDispatcher.jspError(ErrorDispatcher.java:88) [:6.0.0.20100911-M5]
          at org.apache.jasper.compiler.Parser.processIncludeDirective(Parser.java:300) [:6.0.0.20100911-M5]
          at org.apache.jasper.compiler.Parser.parseIncludeDirective(Parser.java:333) [:6.0.0.20100911-M5]
          at org.apache.jasper.compiler.Parser.parseDirective(Parser.java:440) [:6.0.0.20100911-M5]
          at org.apache.jasper.compiler.Parser.parseElements(Parser.java:1398) [:6.0.0.20100911-M5]
          at org.apache.jasper.compiler.Parser.parse(Parser.java:130) [:6.0.0.20100911-M5]

      ...

       

      Caused by: java.lang.ClassNotFoundException: org.apache.jsp.layouts.mainLayout_jsp
          at java.net.URLClassLoader$1.run(URLClassLoader.java:202) [:1.6.0_20]
          at java.security.AccessController.doPrivileged(Native Method) [:1.6.0_20]

       

       

      ...so, either it's not precompiling the mainLayout.jsp into mainLayout_jsp.java, or once it has precompiled it, it's lost.

       

      mainLayout.jsp looks like this

       

      <%@ include file="/layouts/tiles.header.jsp" %>

            <table>

              <tr>
              <td width="80%"><tiles:insert attribute="body"/></td>
              </tr>
            </table>
      <%@ include file="/layouts/tiles.footer.jsp" %>

       

      ...not all that complicated.  is there something new in as6 that requires setting to find the .JSPs or results of compilation?  is there a classloader issue here?

       

      this happens whether the EAR is deployed in farmed-apps or deploy.

       

      thanks in advance if anybody can help with this one.