1 Reply Latest reply on Oct 12, 2010 8:55 AM by Andrew Smith

    Problem with Portlet Preferences in "cluster" profile

    Andrew Smith Newbie

      When I set the exo.profiles runtime property to cluster portlet preferences appear to not save for the first transaction.

       

      Steps to repeat.

       

      1. Install the GateIn deployment just as you would if you first pulled it down and ran it.

      2. Update run.conf to add the -Dexo.profiles=cluster parameter to the JAVA_OPTS if you are running the sh file on unix or update this same attribute in run.conf.bat if running on windows

      3. Start up the server

      4. Log in as root and navigate to configure the dashboard

      5. Edit the page and remove the dashboard portlet and add the iframe portlet, saving will take you back to the portlet

      6. Select to edit portlet preferences

      7. Do not change the url and save (the prefs are not yet in the JCR because they are the default)

      8. Select to edit the portlet again

      9. Change the prefs to blog.gatein.org/2010/05/gatein-31-cr1.html and save.

      10. Note you are still on the original GateIn blog and not on blog.gatein.org/2010/05/gatein-31-cr1.html

      11. Select the link from the dashboard pulldown to go to the exact same page.

      12. Now you are on blog.gatein.org/2010/05/gatein-31-cr1.html.

       

      Has this issue been addressed in any JIRA tickets?  My preliminary search did not yield any.  Also any ideas on a work around?  My product will more than likely be ready to go before the next major version releases.

       

      Any help on the issue would be greatly appreciated.