5 Replies Latest reply on Oct 22, 2010 6:28 AM by sorna sundari

    rich:modalPanel is not poping up in IE

    sorna sundari Newbie

      Hi People,

       

      Am using rich:modalPanel in our application as many as possible.

       

      Am using the following snippet to render that panel;

       

                               <a4j:commandButton
                                  styleClass="btnBlue" value="Proceed" reRender="mainwindow"
                                  action="#{backing_cmsDashboard.transferDomainModalAction}"
                                  onclick="disableButtonAndShowLoadingInfoWindow(this.id);"
                                  oncomplete="#{rich:component('domainTransfermodal')}.show()"/>

       

       

      It says the following error in IE8:

       

      framework.page.js.jsf

       

      User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; InfoPath.2; FDM; AskTB5.6)
      Timestamp: Sat, 9 Oct 2010 07:35:08 UTC

       


      Message: Unknown runtime error

       

      Also for some modalPanels, they are not getting closed.

       

      code snippet for close image at the right corner of the modal panel:

       

      <h:panelGroup>
                  <h:graphicImage style="cursor:pointer"
                      id="milestoneupdateCloseModalHideImgLink" value="#{appConstants.cdnMpImageClose}" />
                  <rich:componentControl
                      for="milestoneUpdateModal,peopleSelectModal"
                      attachTo="milestoneupdateCloseModalHideImgLink" operation="hide"
                      event="onclick" id="milestoneUpdateCloseModalHide" />
              </h:panelGroup>

       

      Also I have cancel button to close.

       

      Even that also not working!!!

       

      <a4j:commandButton styleClass="btnRed" value="Cancel" onclick="#{rich:component('milestoneUpdateModal')}.hide();cancelEvent()" />

       

       

      Please let me know the issues in IE8. These things are fine in firebug.

       

       

      Thanks in Advance,

      Sorna.K