2 Replies Latest reply on Oct 22, 2010 11:22 AM by apparaonali

    Jboss6 M4 test suite results

    apparaonali Newbie


        Where can I find the Jboss6 M4 test suite results? I am very new to web technologies.

      As a part of our new project evaluation I am running jboss6 M4 test cases.

      I downloaded the sources for Jboss6 M4 and ran test suites. There are around 100 failures and 1100 errors.


      Can any one help me?




        • 1. Re: Jboss6 M4 test suite results
          jaikiran pai Master

          Which exact tests are you running? And what kind of evaluation are you doing?


          I don't know if 6.0.0.M4 had 100% test pass percentage, but certainly it didn't have 100 failures and 1100 errors. The testsuite runs against the AS trunk are publicly published as part of the nightly Hudson job here https://hudson.jboss.org/hudson/job/JBoss-AS-6.0.x-testSuite-sun16/

          1 of 1 people found this helpful
          • 2. Re: Jboss6 M4 test suite results
            apparaonali Newbie

            Thanks for your reply. This is really helpful reply.

            We are planning to use jbossAS for making our tolls web based. As a part of that I was told to run the testsuite of jboss and asked to generate results as well as test coverage report.

            I ran the following command in "testsuite" directory and it failed in middle due to OutOfmemoryError then ran remaing tests individually by copying all the targes in a file and called it. I changed -Xmx512m to -Xmx1024m. Then all I was able to run tests and report. Here is the list of targets in the file



            ./build.bat jboss-minimal-tests
            ./build.bat jboss-all-config-tests
            ./build.bat tests-profileservice
            ./build.bat tests-bootstrap-dependencies
            ./build.bat tests-springdeployer
            ./build.bat tests-clustering-all-stacks
            ./build.bat tomcat-ssl-tests
            ./build.bat tomcat-sso-tests
            ./build.bat tomcat-sso-clustered-tests
            ./build.bat tomcat-webctx-tests
            ./build.bat tomcat-federation-tests
            ./build.bat tests-binding-manager
            ./build.bat tests-aop-scoped
            ./build.bat tests-clustered-profileservice
            ./build.bat tests-web-ondemand-disabled
            ./build.bat tests-jts
            ./build.bat tests-jacc-security
            ./build.bat tests-jacc-security-allstarrole
            ./build.bat tests-jacc-securitymgr
            ./build.bat tests-mod_cluster
            ./build.bat tests-ha-mod_cluster
            ./build.bat tests-osgi
            ./build.bat tests-standalone-aop-unit
            ./build.bat tests-compatibility
            ./build.bat tests-treecacheaop-unit
            ./build.bat tests-xml-unit
            ./build.bat tests-stax
            ./build.bat tests-aop-scoped-generated-adviso
            ./build.bat tests-bpel
            ./build.bat tests-jbossmessaging-cluster
            ./build.bat tests-all-classloader-leak
            ./build.bat tests-scripts
            ./build.bat tests-scripts-noserver
            ./build.bat tests-db
            ./build.bat tests-matrix
            ./build.bat tests-hornetq
            ./build.bat smoke-tests
            ./build.bat stress-tests
            ./build.bat tests-report


            After that chcked report and here is summary

            TestsFailuresErrorsSuccess rateTime


            Most errors from

            tests-db -> all error (error - Could not obtain connection to any of these urls: localhost:1099 and discovery failed with error: javax.naming.CommunicationException: Receive timed out [Root exception is java.net.SocketTimeoutException: Receive timed out] at org.jnp.interfaces.NamingContext.discoverServer(NamingContext.java:1690) at org.jnp.interfaces.NamingContext.checkRef(NamingContext.java:1761))

            tests-jbossmessaging -> all errors


            - nested throwable: (java.lang.NullPointerException)

            org.jboss.util.NestedRuntimeException: - nested throwable: (java.lang.NullPointerException)
                 at org.objectweb.jtests.jms.framework.PubSubTestCase.setUp(PubSubTestCase.java:156)
                 at org.jboss.test.jms.JoramUnitTestCase$TestProxy.run(JoramUnitTestCase.java:163)
                 at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
                 at junit.extensions.TestSetup$1.protect(TestSetup.java:23)
                 at junit.extensions.TestSetup.run(TestSetup.java:27)
            Caused by: java.lang.NullPointerException
                 at java.util.Properties$LineReader.readLine(Properties.java:418)
                 at java.util.Properties.load0(Properties.java:337)
                 at java.util.Properties.load(Properties.java:325)
                 at org.objectweb.jtests.jms.framework.JMSTestCase.getProviderProperties(JMSTestCase.java:87)
                 at org.objectweb.jtests.jms.framework.PubSubTestCase.setUp(PubSubTestCase.java:127)



            I don't know whether I can tun like that or not and what are targets I supposed to use.

            I am writing all my quereis here based on above details. Can you please send your comments below queries.

            1. How to solve th problem OutOfMemoryError when I run the command "builds.bat tests"?

            2. What are the targets I supposed to call for executing the testcases?

            3. I could not generate coveerage report as tests are in separate directory. Emma/cobertura/clover none of them giving coverage.

                Where can I find the test coverage report?


            I have googling and searching for the information and didn't it.

            Can you please help me as I don't have any other source to get info?