1 Reply Latest reply on Oct 25, 2010 3:39 PM by Dimitar Zlatkov

    Post office joining wrong cluster

    Dimitar Zlatkov Newbie

      Hi,

       

      I'm running into a problem where:

       

      1. I have two or more clusters.

      2. Each cluster has 3 nodes, and each jboss instance is started with -Djboss.messaging.ServerPeerID=<NODE_NUMBER>, where the node number is 1,2 or 3.

       

      Looking at the logs, I'm seeing that JBoss recognizes the distinct clusters, but the messaging system does not.

       

      JBoss 4.2.3

      JBM 1.4.5

       

      I'm in the process of changing the default JBossMQ into JBM and I'm running into this issue.

       

      Logs:

       

       

      2010-10-22 17:32:29,593 INFO  [org.jboss.jms.server.ServerPeer] JBoss Messaging 1.4.5.GA server [1] started
      2010-10-22 17:32:30,058 INFO  [STDOUT]
      -------------------------------------------------------
      GMS: address is 10.1.17.75:46199
      -------------------------------------------------------
      2010-10-22 17:32:30,062 INFO  [STDOUT]
      -------------------------------------------------------
      GMS: address is 10.1.17.75:7900
      -------------------------------------------------------
      2010-10-22 17:32:37,107 INFO  [org.jboss.messaging.core.impl.postoffice.GroupMember] org.jboss.messaging.core.impl.postoffice.GroupMember$ControlMembershipListener@239d5fe6 got new view [10.1.19.104:49717|7] [10.1.19.104:49717, 10.1.19.92:54890, 10.1.19.91:53573, 10.1.17.75:46199], old view is null
      2010-10-22 17:32:37,108 INFO  [org.jboss.messaging.core.impl.postoffice.GroupMember] I am (10.1.17.75:46199)
      2010-10-22 17:32:37,108 INFO  [org.jboss.messaging.core.impl.postoffice.GroupMember] New Members : 4 ([10.1.19.104:49717, 10.1.19.92:54890, 10.1.19.91:53573, 10.1.17.75:46199])
      2010-10-22 17:32:37,108 INFO  [org.jboss.messaging.core.impl.postoffice.GroupMember] All Members : 4 ([10.1.19.104:49717, 10.1.19.92:54890, 10.1.19.91:53573, 10.1.17.75:46199])
      2010-10-22 17:32:53,000 ERROR [org.jboss.messaging.util.ExceptionUtil] org.jboss.messaging.core.jmx.MessagingPostOfficeService@3b76d662 startService
      java.lang.IllegalArgumentException: Cannot start post office since there is already a post office in the cluster with the same node id (1). Are you sure you have given each node a unique node id during installation?

      at org.jboss.messaging.core.impl.postoffice.MessagingPostOffice.start(MessagingPostOffice.java:378)
              at org.jboss.messaging.core.jmx.MessagingPostOfficeService.startService(MessagingPostOfficeService.java:462)
              at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:289)
              at org.jboss.system.ServiceMBeanSupport.start(ServiceMBeanSupport.java:196)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:592)

      ... <omitted for brevity>

      2010-10-22 17:32:53,004 WARN  [org.jboss.system.ServiceController] Problem starting service jboss.messaging:service=PostOffice
      java.lang.IllegalArgumentException: Cannot start post office since there is already a post office in the cluster with the same node id (1). Are you sure you have given each node a unique node id du
      ring installation?
              at org.jboss.messaging.core.impl.postoffice.MessagingPostOffice.start(MessagingPostOffice.java:378)
              at org.jboss.messaging.core.jmx.MessagingPostOfficeService.startService(MessagingPostOfficeService.java:462)
              at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:289)
              at org.jboss.system.ServiceMBeanSupport.start(ServiceMBeanSupport.java:196)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:592)

      ... <omitted for brevity>

      -------------------------------------------------------
      GMS: address is 10.1.17.75:58939
      -------------------------------------------------------
      2010-10-22 17:33:04,753 INFO  [org.jboss.jmx.adaptor.snmp.agent.SnmpAgentService] SNMP agent going active
      2010-10-22 17:33:05,318 INFO  [org.jboss.ha.framework.interfaces.HAPartition.engine-dev] Initializing
      2010-10-22 17:33:05,361 INFO  [STDOUT]
      -------------------------------------------------------
      GMS: address is 10.1.17.75:48494
      -------------------------------------------------------
      2010-10-22 17:33:07,371 INFO  [org.jboss.ha.framework.interfaces.HAPartition.engine-dev] Number of cluster members: 1
      2010-10-22 17:33:07,372 INFO  [org.jboss.ha.framework.interfaces.HAPartition.engine-dev] Other members: 0
      2010-10-22 17:33:07,372 INFO  [org.jboss.ha.framework.interfaces.HAPartition.engine-dev] Fetching state (will wait for 30000 milliseconds):
      2010-10-22 17:33:07,372 INFO  [org.jboss.ha.framework.interfaces.HAPartition.engine-dev] State could not be retrieved (we are the first member in group)
      2010-10-22 17:33:09,857 INFO  [org.jboss.ha.jndi.HANamingService] Started ha-jndi bootstrap jnpPort=1100, backlog=50, bindAddress=/10.1.17.75
      2010-10-22 17:33:09,873 INFO  [org.jboss.ha.jndi.DetachedHANamingService$AutomaticDiscovery] Listening on /10.1.17.75:1102, group=230.0.0.4, HA-JNDI address=10.1.17.75:1100
      2010-10-22 17:33:10,189 INFO  [STDOUT]
      -------------------------------------------------------
      GMS: address is 10.1.17.75:39147
      -------------------------------------------------------

       

      Any clues to what's going on?