0 Replies Latest reply on Oct 29, 2010 6:25 AM by Tarlok Chand

    Error  to  mod-cluster configured  with  JBOSS 5.1 GA

    Tarlok Chand Newbie

      Please

       

      Hi  i  try  to  configured  dynamic  Jboss cluster using mod-cluser

      Whent i  start jboss it show following  error.

       

      error.png

       

       

      setting are

       

       

      step1)  extract  mod_cluster-1.1.0.Final-bin.tar.gz

      and copy the  mod

        # cp -r mod_cluster.sar/ $JBOSS_DEPLOY  ( $JBOSS_DEPLOY= /data2/jboss/server/all/deploy)

       

      step2) copy the lib into jboss home

      mod_cluster-1.1.0.Final-bin.tar.gz_FILES]# cp -r  JBossWeb-Tomcat/lib/  $JBOSS_HOME

       

      step 3 )  Edit the   jbossweb.sar/server.xml

      and add  these  two line

       

      <Listener className="org.jboss.web.tomcat.service.deployers.MicrocontainerIntegrationLifecycleListener" delegateBeanName="HAModClusterListener"/>

       

      <Listener className="org.jboss.modcluster.catalina.ModClusterListener" advertise="true"/>

       

       

      Step 4) add the one line into file  "jbossweb.sar/META-INF/jboss-beans.xml"

       

      <depends>HAModClusterListener</depends>

       

      step 5) Edit the File mod_cluster.sar/META-INF/mod_cluster-jboss-beans.xml

      add  these line

      <property name="proxyList">${jboss.mod_cluster.proxyList:192.168.2.197:6666}</property>

       

      After run the  jboss the show  error   

      "Deplyment Missing Error"

       

      Please Guide me where i  am  wrong  .