4 Replies Latest reply on Nov 4, 2010 5:10 AM by yahya hugirat

    new Error with remote glassfih

    yahya hugirat Newbie

      now i get this error when i run the tests.

       

      Fehlermeldung

      com.sun.logging.LogDomains.getLogger(Ljava/lang/Class;Ljava/lang/String;)Ljava/util/logging/Logger;

      Stacktrace

      java.lang.NoSuchMethodError: com.sun.logging.LogDomains.getLogger(Ljava/lang/Class;Ljava/lang/String;)Ljava/util/logging/Logger;
           at org.glassfish.deployapi.SunDeploymentFactory.<clinit>(SunDeploymentFactory.java:87)
           at java.lang.Class.forName0(Native Method)
           at java.lang.Class.forName(Class.java:169)
           at org.jboss.arquillian.container.jsr88.remote_1_2.JSR88RemoteContainer.initDeploymentManager(JSR88RemoteContainer.java:240)
           at org.jboss.arquillian.container.jsr88.remote_1_2.JSR88RemoteContainer.start(JSR88RemoteContainer.java:101)
           at org.jboss.arquillian.impl.handler.ContainerStarter.callback(ContainerStarter.java:52)
           at org.jboss.arquillian.impl.handler.ContainerStarter.callback(ContainerStarter.java:41)
           at org.jboss.arquillian.impl.event.MapEventManager.fire(MapEventManager.java:63)
           at org.jboss.arquillian.impl.context.AbstractEventContext.fire(AbstractEventContext.java:115)
           at org.jboss.arquillian.impl.EventTestRunnerAdaptor.beforeSuite(EventTestRunnerAdaptor.java:68)
           at org.jboss.arquillian.junit.Arquillian.<init>(Arquillian.java:89)
           at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
           at java.lang.reflect.Constructor.newInstance(Constructor.java:513)

      I have searched the net and I have found that I have to add the appserv-rt.jar file, I have added deferent versions of it but no success
        • 1. Re: new Error with remote glassfih
          Aslak Knutsen Master

          Which glassfish version are you trying?

          • 3. Re: new Error with remote glassfih
            Aslak Knutsen Master

            only the deployment client client should be needed:

             

             

                    <dependency>
                        <groupId>org.glassfish.deployment</groupId>
                        <artifactId>deployment-client</artifactId>
                        <version>3.0.1-b19</version>
                     <scope>test</scope>
                    </dependency>
            

             

             

            http://docs.jboss.org/arquillian/reference/latest/en-US/html_single/#container.glassfish-remote-3

            • 4. Re: new Error with remote glassfih
              yahya hugirat Newbie
              because of ant I add the jar files manually, so I have this list of jar's:

                      lib/arquillian-testenricher-resource-1.0.0-20101012.080223-138.jar
                      lib/gf-client.jar
                      lib/javax.enterprise.deploy-3.0.1-b19.jar
                      lib/glassfish-3.0.1-b19.jar
                      lib/CopyLibs
                      lib/CopyLibs/org-netbeans-modules-java-j2seproject-copylibstask.jar
                      lib/appserv-deployment-client.jar
                      lib/nblibraries.properties
                      lib/glassfish-api-3.0.1-b19.jar
                      lib/javax.inject-1.jar
                      lib/deployment-client-3.0.1-b19.jar
                      lib/arquillian-protocol-servlet-3-1.0.0-20101012.080223-66.jar
                      lib/arquillian-glassfish-remote-3-1.0.0-20100913.080058-50.jar
                      lib/appserv-rt-3.1-b27.jar
                      lib/shrinkwrap-impl-base-1.0.0-alpha-11.jar
                      lib/javaee.jar
                      lib/arquillian-api-1.0.0-20101012.080223-164.jar
                      lib/shrinkwrap-api-1.0.0-alpha-11.jar
                      lib/javax.ejb-3.0.jar
                      lib/arquillian-glassfish-remote-3-1.0.0-20101028.083646-1.jar
                      lib/glassfish-api-3.0.1-b20.jar
                      lib/arquillian-spi-1.0.0-20101012.080223-160.jar
                      lib/shrinkwrap-spi-1.0.0-alpha-11.jar
                      lib/arquillian-junit-1.0.0-20101012.080223-157.jar
                      lib/shrinkwrap-extension-glassfish-1.0.0-alpha-11.jar
                      lib/sun-as-jsr88-dm.jar
                      lib/arquillian-testenricher-cdi-1.0.0-20101012.080223-139.jar
                      lib/javax.annotation-3.0.jar
                      lib/arquillian-testenricher-ejb-1.0.0-20101012.080223-139.jar
                      lib/arquillian-protocol-servlet-3-1.0.0.Alpha4.jar
                      lib/eclipselink
                      lib/eclipselink/eclipselink-javax.persistence-2.0.jar
                      lib/eclipselink/eclipselink-2.0.2.jar
                      lib/eclipselink/javaee6-doc-api.zip
                      lib/persistence-api-1.0.jar
                      lib/arquillian-jsr88-remote-1.2-1.0.0-20100913.080058-49.jar
                      lib/javaee-endorsed-api-6.0
                      lib/javaee-endorsed-api-6.0/webservices-api-osgi.jar
                      lib/javaee-endorsed-api-6.0/jaxb-api-osgi.jar
                      lib/javaee-endorsed-api-6.0/javaee6-doc-api.zip
                      lib/javaee-endorsed-api-6.0/javax.annotation.jar
                      lib/javax.servlet-3.0.jar
                      lib/deployment-common-3.0.1-b19.jar
                      lib/arquillian-impl-base-1.0.0-20101012.080223-158.jar
                      lib/eclipselink-2.0.2.jar
                      lib/junit-4.8.1.jar
                      lib/arquillian-jsr88-remote-1.2-1.0.0-20101028.083646-1.jar

              when I remove the deployment-common or appserv-deployment I get errors.
              with this constellation I get the above error.