1 2 3 Previous Next 43 Replies Latest reply: Dec 1, 2010 9:39 AM by Igor JStarter Go to original post RSS
  • 30. Re: RiftSaw - how to invoke an external web service
    Robert (Bob) Brodt Newbie

    Hi Igor,


    I tried several times with my latest build of the BPEL editor, but I'm unable to reproduce the problem. The only differences in the artifacts.wsdl AFTER creating the new partnerlink was the addition of the new partnerlink definition, just before the <types> element (which is what I would  expect):


    <!-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
         TYPE DEFINITION - List of services participating in this BPEL process
         The default output of the BPEL designer uses strings as input and
         output to the BPEL Process. But you can define or import any XML
         Schema type and us them as part of the message types.
         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -->   
        <plnk:partnerLinkType name="calcPLT">
        <plnk:role name="calcClientRole" portType="wsdl:RectangleCalculator"/>
        <import location="RectangleCalculator.wsdl" namespace="http://rectangle.bple.tps"/>
            <schema attributeFormDefault="unqualified"


    The section in bold is what was added to the WSDL. It is possible that this problem has been fixed as part of another bug. If you have time, can you please try a more recent build of the JBoss tools (use a nightly build) and see if you still get the error?






    BTW, I also replied to your question in the JBoss tools community forum at http://community.jboss.org/thread/158650?tstart=0

  • 31. Re: RiftSaw - how to invoke an external web service
    Igor JStarter Novice

    I have a external webservice which uses 2wsdl... Manager.wsdl imports ManagerWS.wsdl...

    It uses basic Username WS security, but I think I'm not that far. It fails with:


    10:21:07,207 INFO  [TomcatDeployment] deploy, ctxPath=/bpelMarin
    10:21:07,442 WARNING [config] Unable to process deployment descriptor for context '/bpelMarin'
    10:21:07,442 INFO  [config] Initializing Mojarra (1.2_12-b01-FCS) for context '/bpelMarin'
    10:21:07,614 INFO  [BpelProcess] Created new process DAO for {http://samples/bpelMarin}bpelMarin-0 (guid=181te2evxg79w3wiq8rsg53lh7d7o8r7)
    10:21:07,614 INFO  [BpelProcess] Created new process DAO for {http://samples/bpelMarin}bpelMarin-0 (guid=181te2evxg79w3wiq8rsg53lh7d7o8r7).
    10:21:07,645 INFO  [BpelServerImpl] Registered process {http://samples/bpelMarin}bpelMarin-0.
    10:21:07,645 INFO  [CronScheduler] Cancelling PROCESS CRON jobs for: {http://samples/bpelMarin}bpelMarin-0
    10:21:07,645 INFO  [CronScheduler] Scheduling PROCESS CRON jobs for: {http://samples/bpelMarin}bpelMarin-0
    10:23:30,477 INFO  [STDOUT] Retrieving document at 'file:/D:/KKISSWORK/jboss-5.1.0.GA/server/default/tmp/5c4o1o20-lssbem-ggnf7rj0-1-ggnflkne-dd/bpelMarin.jar/bpelMarinArtifacts.wsdl'.
    10:23:30,493 INFO  [STDOUT] Retrieving document at 'CdrManagerWS.wsdl', relative to 'file:/D:/KKISSWORK/jboss-5.1.0.GA/server/default/tmp/5c4o1o20-lssbem-ggnf7rj0-1-ggnflkne-dd/bpelMarin.jar/bpelMarinArtifacts.wsdl'.
    10:23:30,571 INFO  [WatchDog] [Endpoint files for {DeploymentUnit bpelMarin}] updated
    10:23:30,759 WARN  [EndpointReferenceContextImpl] Map access not implemented
    10:23:30,759 ERROR [UDDIRegistrationImpl] Could not find UDDI Clerk named BPELClerk
    org.apache.commons.configuration.ConfigurationException: Could not find UDDI Clerk named BPELClerk


    Any idea what the problem might be?


    Thank you!

  • 32. Re: RiftSaw - how to invoke an external web service
    Kurt Stam Master

    Hi Igor,


    Upon deployment of the BPEL Process it is trying to register it into UDDI (in the riftsaw.sar/bpel.properties: bpel.uddi.registration=true). If you are not using riftsaw and JBESB together, you probably want to turn this off (set the false), or else you will need to install your own jUDDI server (or deploy JBESB which ships with it), or use an external UDDI.



  • 33. Re: RiftSaw - how to invoke an external web service
    Igor JStarter Novice

    Hi, thank you for your reply, but it doesn't solve my problem...


    I'm using JBossAS5.1, JBossESB4.8 and RiftSaw2.1, so I use it together...

    And I had no problems with other wsdls, projects.. What could be the difference ???


    When i changed bpel.uddi.registration to false, there was no change in the log... so I'll change it back...

    My bpel.properties:

    # if set to true will lookup BPEL endpoints in a UDDI Registry.
    # this uses the juddi-client-3.0.x and the uddi client config can be set in the uddi.xml
    # file
    # implementation of the client integration class
    # the uddi client config in case you want to use your own client config rather then
    # jbossesb.saw/esb.uddi.client.xml. Commented out by default.
    # only if you don't specify the bpel.uddi.config you need to specify the name of the clerk manager
    # name of the clerk




    Do you have any other idea ?


    BR, Igor!

  • 34. Re: RiftSaw - how to invoke an external web service
    Kurt Stam Master

    Hi Igor,


    1. Can you check your jbossesb.sar/esb.juddi.client.xml to make sure you have the following section

            <clerks registerOnStartup="true">
               <clerk name="BPELClerk" node="default" publisher="jbossesb" password="jbossesb" />


    2. Do you get the same error when you deploy any of the quickstarts, or is it limited to your 'bpelMarin' process.



  • 35. Re: RiftSaw - how to invoke an external web service
    Igor JStarter Novice

    I was working on the ESB for 3 weeks and was able to deploy some processes, now I workingwith Riftsaw, but it's the first time i see BPELClerk and UDDI problems ...


    No, i don't have that lines. In my jbossesb.sar/esb.juddi.client.xml is this:

        <manager name="esb-registry">
                    <!-- required 'default' node -->
                    <description>Main jUDDI node</description>
                    <!-- JAX-WS Transport
                    <!-- In VM Transport Settings -->
                    <!-- RMI Transport Settings
                    <description>jUDDI console node</description>
                    <!-- In VM Transport Settings -->

  • 36. Re: RiftSaw - how to invoke an external web service
    Kurt Stam Master



    I think you installed RiftSaw before JBESB. You need to install RiftSaw last. Can you try that? And then check if you have the Clerk?



  • 37. Re: RiftSaw - how to invoke an external web service
    Igor JStarter Novice

    No, I 100% installed the ESB first, and when ESB was working, i installed Riftsaw 2.1.


    I'm afraid of doing that... Ok.. Probably I could try that at home..


    If any other ideas...

  • 38. Re: RiftSaw - how to invoke an external web service
    Kurt Stam Master

    You have to try instaling RiftSaw again. It is the only way to fix your configuration. Just make a backup copy before you start. BTW, you will need to destroy your jUDDI database if you started JBESB before installing RiftSaw so jUDDI can reseed. This can be done by deleting the data directory. However this is unrelated to the current issue we are trying to solve.



  • 39. Re: RiftSaw - how to invoke an external web service
    Igor JStarter Novice

    Hey Gary, i have a question and I'm sure you know .)


    I deployed my BPEL process to JBoss with the Apache ODE descriptor. But now I have my JBoss behind a FIREWALL.


    I configured the Firewall to open ports and pass everythink from the external IP to my local.


    I started JBoss with run.sh -Djboss.bind.address=localIP. JBoss starts and exposes the WSDL correctly, but JBoss also generates the soap:address and import address and adds it to the wsdl. This generated location are localIP, which I can't access.


    How can i tell JBoss that he shouldn't change my soap:address in my artifacts.wsdl ?


    How to tell him generate a hardcoded url for all WS ?


    In forums they say I should change the deployers/jbossws.deployer/META-INF/jboss-beans.xml. I have this file only in the all distributin, but not in my default configuration folder, which I'm using. If i change the jboss-beans.xml in the all folder, nothing changes... The generated WSDL contains always the jboss.bind.address




    Does somebody has any idea ???

  • 40. Re: RiftSaw - how to invoke an external web service
    Kurt Stam Master

    Hi Igor,


    If you want to update the settings on server generated WSDLs then you can play with the settings in the



    <property name="webServiceHost">${jboss.bind.address}</property>
    <property name="modifySOAPAddress">true</property>

    <property name="webServiceSecurePort">8443</property>
    <property name="webServicePort">8080</property>


    If that does not work, please open a JIRA at the JBossWS project, and attach a mini deployable artifact along with your config file.




  • 41. Re: RiftSaw - how to invoke an external web service
    Igor JStarter Novice

    SOLVED !


    deployers/jbossws.deployer/META-INF/jboss-beans.xml: (only in server/all)

    Nobody replied so i don't know if u have other configuration, but...

    The upper file exists only in jboss/server/all and if I changed that, nothing changed, because I'm using the default configuration.


    Under \jboss-5.1.0.GA\server\default\deployers\jbossws.deployer\META-INF in found stack-agnostic-jboss-beans.xml.

    And this was the file i had to change !!! I hardcoded an IP and JBoss takes this IP always it generates a wsdl.


    And now... in works .) Jiiiiiiiiiiiiiha

  • 42. Re: RiftSaw - how to invoke an external web service
    Gary Brown Master

    Hi Igor


    Thanks for the information - I'll make sure it is added to the user guide.


    BTW - this thread is getting very long, containing a number of different discussions, so if you don't mind next time can you start a new thread with a title specific to the discussion point, as it makes it easier for other users to find the relevant information later on. Thanks.




  • 43. Re: RiftSaw - how to invoke an external web service
    Igor JStarter Novice


    Gary... you are my hero .)  and I'm glad that probably this time I helped a little.

1 2 3 Previous Next