3 Replies Latest reply on Nov 12, 2010 7:43 AM by Jacobo Chamorro

    inplaceInput hover style problem

    Jacobo Chamorro Newbie

      Hi there,

       

      I'm having quite a big problem with inplaceInput (RichFaces 3.3.3.Final version). I have several inplaceInput in my page, some of them having a different style (styleClass or viewClass, same thing happens). I'll post an example with two of them but same problem applies with more than two.

       

      <a4j:form id="formPaciente">
          <p>
              <rich:inplaceInput id="ip1" value="hola" viewClass="distinto" />
          </p>
          <p>
              <rich:inplaceInput id="ip2" value="mundo" />
          </p>
      </a4j:form>
      

       

      When I hover the mouse out of the second inplaceIniput it gets the style of the first one added to its style classes.

       

      This is generated span element before hovering:

       

      <span style="" id="formPaciente:ip2" class="rich-inplace rich-inplace-input rich-inplace-view ">
           ...
      </span>
      
      

       

      And this is the same span after:

       

      <span style="" id="formPaciente:ip2" class="rich-inplace rich-inplace-input rich-inplace-view distinto">
           ...
      </span>
      
      

       

      In fact all inplaceInput get added all the style attribute from different components. So if you have three inplaceInput with style "distinto" and aonther one with style "prueba" when after hovering mouse over any inplaceInput in the page it gets as style attribute "distinto distinto distinto prueba" (and all the richfaces styles, ofc).

       

      Hope someone can give me a hand. Thanks in advance.