13 Replies Latest reply on Dec 13, 2010 6:21 AM by Max Rydahl Andersen

    IBM RAD Version: 8.0.1 + Websphere 7 + Right Jboss Tools Version?

    Bhanchand Prasad Newbie

      IBM RAD Version: 8.0.1 + Websphere 7 what Seam plugins Jboss Tools version to use? I tried the default plugins that go with Eclipse 3.6 and it will not install...missing core.0.0.0 dependencies...

       

      Successfully (no errors) installed the plugins from http://download.jboss.org/jbosstools/updates/JBossTools-3.0.3.GA

      However this did not show  New "Seam" project or Seam Perspective options.

       

      Also unzipped JBossTools-ALL-win32-3.0.3.v200910211631N-H194-GA the contents into the eclipse folder containing eclipse.exe (C:\Program Files\IBM\SDP\eclipse.exe) . This does not enable show a "Seam" project option in RAD.

       

      Checked "Preferences>Capabilities" and see no "Seam" reference.

       

      Missing any steps?

        • 1. Re: IBM RAD Version: 8.0.1 + Websphere 7 + Right Jboss Tools Version?
          Max Rydahl Andersen Master

          I don't know what IBM RAD Version 8.0.1 contains, but if it is Eclipse 3.6 then you need to use the Eclipse 3.6 updatesite

          (http://download.jboss.org/jbosstools/updates/development/)

           

          You can find that overview at http://jboss.org/tools/download

          • 2. Re: IBM RAD Version: 8.0.1 + Websphere 7 + Right Jboss Tools Version?
            Bhanchand Prasad Newbie

              Hibernate Tools     3.3.0.v20101016-0359-H111-Beta1     org.hibernate.eclipse.feature.feature.group
              Seam Tools          3.2.0.v20101016-0359-H111-Beta1     org.jboss.tools.seam.feature.feature.group
             
              Cannot complete the install because one or more required items could not be found.
                Software being installed: JBoss Tools RichFaces 3.2.0.v20101016-0359-H111-Beta1 (org.jboss.tools.richfaces.feature.feature.group 3.2.0.v20101016-0359-H111-Beta1)
                Missing requirement: JBoss Tools RichFaces 3.2.0.v20101016-0359-H111-Beta1 (org.jboss.tools.vpe 3.2.0.v20101016-0359-H111-Beta1) requires 'bundle org.eclipse.wst.xml.xpath.core 0.0.0' but it could not be found
                Cannot satisfy dependency:
                  From: JBoss Tools RichFaces 3.2.0.v20101016-0359-H111-Beta1 (org.jboss.tools.richfaces.feature.feature.group 3.2.0.v20101016-0359-H111-Beta1)
                To: org.jboss.tools.vpe [3.2.0.v20101016-0359-H111-Beta1]
               

            Thanks for your reply..made some progress...

            The plugins from http://download.jboss.org/jbosstools/updates/development/ installed with no errors for the following:

              Hibernate Tools 3.3.0.v20101016-0359-H111-Beta1 org.hibernate.eclipse.feature.feature.group

              Seam Tools 3.2.0.v20101016-0359-H111-Beta1 org.jboss.tools.seam.feature.feature.group

             

            However the installation of JBoss Tools RichFaces returns an error as follows:

              Cannot complete the install because one or more required items could not be found.

                Software being installed: JBoss Tools RichFaces 3.2.0.v20101016-0359-H111-Beta1 (org.jboss.tools.richfaces.feature.feature.group 3.2.0.v20101016-0359-H111-Beta1)

                Missing requirement: JBoss Tools RichFaces 3.2.0.v20101016-0359-H111-Beta1 (org.jboss.tools.vpe 3.2.0.v20101016-0359-H111-Beta1) requires 'bundle org.eclipse.wst.xml.xpath.core 0.0.0' but it could not be found

                Cannot satisfy dependency:

                  From: JBoss Tools RichFaces 3.2.0.v20101016-0359-H111-Beta1 (org.jboss.tools.richfaces.feature.feature.group 3.2.0.v20101016-0359-H111-Beta1)

                To: org.jboss.tools.vpe [3.2.0.v20101016-0359-H111-Beta1]

            • 3. Re: IBM RAD Version: 8.0.1 + Websphere 7 + Right Jboss Tools Version?
              Bhanchand Prasad Newbie
              Cannot complete the install because one or more required items could not be found.
                Software being installed: JBoss Tools RichFaces 3.2.0.v20101122-2055-H270-Beta2 (org.jboss.tools.richfaces.feature.feature.group 3.2.0.v20101122-2055-H270-Beta2)
                Missing requirement: JBoss Tools RichFaces 3.2.0.v20101122-2055-H270-Beta2 (org.jboss.tools.vpe 3.2.0.v20101122-2055-H270-Beta2) requires 'bundle org.eclipse.wst.xml.xpath.core 0.0.0' but it could not be found
                Cannot satisfy dependency:
                  From: JBoss Tools RichFaces 3.2.0.v20101122-2055-H270-Beta2 (org.jboss.tools.richfaces.feature.feature.group 3.2.0.v20101122-2055-H270-Beta2)
                  To: org.jboss.tools.vpe [3.2.0.v20101122-2055-H270-Beta2]

              Also tried the http://download.jboss.org/jbosstools/updates/nightly/trunk/ and the following error


              Cannot complete the install because one or more required items could not be found.

                Software being installed: JBoss Tools RichFaces 3.2.0.v20101122-2055-H270-Beta2 (org.jboss.tools.richfaces.feature.feature.group 3.2.0.v20101122-2055-H270-Beta2)

                Missing requirement: JBoss Tools RichFaces 3.2.0.v20101122-2055-H270-Beta2 (org.jboss.tools.vpe 3.2.0.v20101122-2055-H270-Beta2) requires 'bundle org.eclipse.wst.xml.xpath.core 0.0.0' but it could not be found

                Cannot satisfy dependency:

                  From: JBoss Tools RichFaces 3.2.0.v20101122-2055-H270-Beta2 (org.jboss.tools.richfaces.feature.feature.group 3.2.0.v20101122-2055-H270-Beta2)

                  To: org.jboss.tools.vpe [3.2.0.v20101122-2055-H270-Beta2]

              • 4. Re: IBM RAD Version: 8.0.1 + Websphere 7 + Right Jboss Tools Version?
                Max Rydahl Andersen Master

                looks like IBM RAD does not contain org.eclipse.wst.xml.xpath.core ?

                 

                Have you tried installing that from Eclipse WTP ?

                • 5. Re: IBM RAD Version: 8.0.1 + Websphere 7 + Right Jboss Tools Version?
                  Bhanchand Prasad Newbie

                  Web Tools Platform(WTP) 3.2.2

                  Thanks for your suggestion.

                  Installed Web Tools Platform(WTP) 3.2.2 from http://download.eclipse.org/webtools/repository/helios

                  Thank for your help...

                   

                  Installed JBoss Tools RichFaces 3.2.0.v20101016-0359-H111-Beta1  successfully from http://download.jboss.org/jbosstools/updates/development/

                   

                  Within RAD I do not see the Seam perspective or New Seam Project options. Are there additional steps involved?

                  Installation includes the following:

                         JBoss Tools RichFaces 3.2.0.v20101016-0359-H111

                         Hibernate Tools 3.3.0.v20101016-0359-H111-Beta1

                         Seam Tools 3.2.0.v20101016-0359-H111-Beta1

                   

                  • 7. Re: IBM RAD Version: 8.0.1 + Websphere 7 + Right Jboss Tools Version?
                    Bhanchand Prasad Newbie

                        JBoss Tools RichFaces     3.2.0.v20101016-0359-H111-Beta1     org.jboss.tools.richfaces.feature.feature.group
                                   XULRunner     1.8.1.3-20070904     org.jboss.tools.xulrunner.feature.feature.group
                        Seam Tools     3.2.0.v20101016-0359-H111-Beta1     org.jboss.tools.seam.feature.feature.group
                                   JBossAS Tools     2.0.2.v200910211631N-H194-GA     org.jboss.ide.eclipse.as.feature.feature.group
                        Hibernate Tools     3.3.0.v20101016-0359-H111-Beta1     org.hibernate.eclipse.feature.feature.group

                    No...I did not see any errors during the installation. Is there a particular file to look for?

                     

                    Checked the Installed Software and it displays the following  

                        JBoss Tools RichFaces 3.2.0.v20101016-0359-H111-Beta1 org.jboss.tools.richfaces.feature.feature.group

                                   XULRunner 1.8.1.3-20070904 org.jboss.tools.xulrunner.feature.feature.group

                        Seam Tools 3.2.0.v20101016-0359-H111-Beta1 org.jboss.tools.seam.feature.feature.group

                                   JBossAS Tools 2.0.2.v200910211631N-H194-GA org.jboss.ide.eclipse.as.feature.feature.group

                        Hibernate Tools 3.3.0.v20101016-0359-H111-Beta1 org.hibernate.eclipse.feature.feature.group

                    • 8. Re: IBM RAD Version: 8.0.1 + Websphere 7 + Right Jboss Tools Version?
                      Alexey Kazakov Master

                      I mean Windows->Show View->Error Log.

                      It looks like JBT plugins were not loaded. And JBoss AS Tools seems to be a reason of it. You have JBossAS Tools 2.0.2 which is not compatible with Seam Tools 3.2. Please install JBossAS Tools 2.2-Beta1.

                      • 9. Re: IBM RAD Version: 8.0.1 + Websphere 7 + Right Jboss Tools Version?
                        Bhanchand Prasad Newbie
                          JBossAS Tools     2.2.0.v20101122-2055-H270-Beta2     org.jboss.ide.eclipse.as.feature.feature.group
                            Seam Tools     3.2.0.v20101124-1304-H279-Beta2     org.jboss.tools.seam.feature.feature.group

                        Installed versions as follows:

                        JBossAS Tools 2.2.0.v20101122-2055-H270-Beta2 org.jboss.ide.eclipse.as.feature.feature.group

                          Seam Tools 3.2.0.v20101124-1304-H279-Beta2 org.jboss.tools.seam.feature.feature.group

                         

                        Also tried with the following

                        JBossAS Tools 2.2.0.v20101016-0359-H111-Beta1 org.jboss.ide.eclipse.as.feature.feature.group

                        Seam Tools 3.2.0.v20101016-0359-H111-Beta1 org.jboss.tools.seam.feature.feature.group

                         

                        No errors in the error log "Windows->Show View->Error Log". However see no option for Seam Perspective or Seam Project.

                        Any suggestions? Thanks a ton for your help.

                        • 10. Re: IBM RAD Version: 8.0.1 + Websphere 7 + Right Jboss Tools Version?
                          Bhanchand Prasad Newbie

                          Thanks for your detailed reply....
                          Update ... Tried installing again...this time with afresh copy of RAD 8.0.1 and JBoss Tools (3.2.0.v20101206-2100-H28-Beta2)
                             Hibernate Tools
                             Seam Tools
                             JBoss Tools RichFaces
                          From
                              JBoss Tools RichFaces     3.2.0.v20101206-2100-H28-Beta2
                          Both Seam and Hibernate installed with no errors and the Seam Perspective is enabled..
                          However the JBoss Richfaces has the following error :
                          Software being installed: JBoss Tools RichFaces 3.2.0.v20101206-2100-H28-Beta2 (org.jboss.tools.richfaces.feature.feature.group 3.2.0.v20101206-2100-H28-Beta2)
                            Missing requirement: JBoss Tools RichFaces 3.2.0.v20101206-2100-H28-Beta2 (org.jboss.tools.vpe 3.2.0.v20101206-2100-H28-Beta2) requires 'bundle org.eclipse.wst.xml.xpath.core 0.0.0' but it could not be found
                            Cannot satisfy dependency:
                              From: JBoss Tools RichFaces 3.2.0.v20101206-2100-H28-Beta2 (org.jboss.tools.richfaces.feature.feature.group 3.2.0.v20101206-2100-H28-Beta2)
                              To: org.jboss.tools.vpe [3.2.0.v20101206-2100-H28-Beta2]

                          Update ... Tried installing again...this time with afresh copy of RAD 8.0.1 and JBoss Tools (3.2.0.v20101206-2100-H28-Beta2)

                             Hibernate Tools

                             Seam Tools

                             JBoss Tools RichFaces

                           

                          From

                          JBoss Tools Aggregate Site - http://download.jboss.org/jbosstools/updates/nightly/trunk/

                              JBoss Tools RichFaces 3.2.0.v20101206-2100-H28-Beta2

                           

                          Both Seam and Hibernate installed with no errors and the Seam Perspective is enabled..

                          However the JBoss Richfaces has the following error :

                           

                          Software being installed: JBoss Tools RichFaces 3.2.0.v20101206-2100-H28-Beta2 (org.jboss.tools.richfaces.feature.feature.group 3.2.0.v20101206-2100-H28-Beta2)

                            Missing requirement: JBoss Tools RichFaces 3.2.0.v20101206-2100-H28-Beta2 (org.jboss.tools.vpe 3.2.0.v20101206-2100-H28-Beta2) requires 'bundle org.eclipse.wst.xml.xpath.core 0.0.0' but it could not be found

                            Cannot satisfy dependency:

                              From: JBoss Tools RichFaces 3.2.0.v20101206-2100-H28-Beta2 (org.jboss.tools.richfaces.feature.feature.group 3.2.0.v20101206-2100-H28-Beta2)

                              To: org.jboss.tools.vpe [3.2.0.v20101206-2100-H28-Beta2]

                           

                          Any thoughts?

                          • 11. Re: IBM RAD Version: 8.0.1 + Websphere 7 + Right Jboss Tools Version?
                            Max Rydahl Andersen Master

                            Same as last time:

                             

                            "looks like IBM RAD does not contain org.eclipse.wst.xml.xpath.core ?

                             

                            Have you tried installing that from Eclipse WTP ?"

                             

                            i.e. add Eclipse update site to get the WTP plugins ? Not sure that RAD will continue to work when you mix it with WTP

                            • 12. Re: IBM RAD Version: 8.0.1 + Websphere 7 + Right Jboss Tools Version?
                              Bhanchand Prasad Newbie

                              New Seam Project
                              ====================================
                              Web module and the EAR are created, np ejb module
                              The web module does not have any seam jars...
                              Failed while installing Seam 2.2
                                      java.lang.NullPointerStructure

                              A little more progress...

                                 Beta 2 is out, cool! Good work guys!

                               

                              Used the latest nightly build, it installs with no errors..

                              However when creating a new seam project get the  following error:

                              Failed while installing Seam 2.2

                                      java.lang.NullPointerStructure

                               

                              The Web module and the EAR are created, but no ejb module

                              Also do not have any seam jars but the web.xml and components.xml is configured...

                               

                              I can create the Ejb module separately. What jars should it contain for the Seam related annotations work within EJBs? A reference to a sample project structure and the references?

                               

                              Thanks for your help.

                              • 13. Re: IBM RAD Version: 8.0.1 + Websphere 7 + Right Jboss Tools Version?
                                Max Rydahl Andersen Master

                                Ill assume what you get is a NullPointerException ?

                                 

                                Please open an issue on issues.jboss.org/browse/JBIDE and include the full stack trace so can track it down.