2 Replies Latest reply on Dec 3, 2010 3:25 PM by John Bailo

    a4j:push does not rerender outputText

    John Bailo Master

      I know there have been some discussion threads on this from 2008, 2009 and a recent bug fix, but when I tried to implement the sample code here:

       

      http://livedemo.exadel.com/richfaces-demo/richfaces/push.jsf 

      (Which runs fine on the demo server, but not on mine.)

       

      what happens is the bean thread runs, updates the property uuid (I monitor in the log) but the jsf page never rerenders the outputText component.

       

      I am running this in Eclipse but have tried using IE and FF.

       

      The only changes I made is that I constructed the page shown below...adding the eventsQueue attribute as recommended.

       

      I put a breakpoint on the getUuid() method and it is called only once at start, never again.

       

      Is there (still) a bug with a4j:push?   These are the older articles that described the problem:

      a4j push fails(sometimes) to rerender target component

      I am using RichFaces 3.3.3 FINAL and JBoss 4.3.2.

       

       

      Here is how I set it up as a managed bean in faces: