0 Replies Latest reply on Dec 2, 2010 10:41 AM by Ziyang Zhang

    Some functions don't work. Need to reload the page.

    Ziyang Zhang Newbie

      This problem only exists in Chrome, not in FF and IE.

       

      Some functions like sort the table or calendar do not work if I don't you the website for a period of time. In Chrome, I need to press ctrl+f5 to reload the page and everything works well after that.

       

      My guess is the scripts loaded from server to the client side expire after a certain time. And when I go to the site again, Chrome does not reload the expired script, so some functions do not work. And after ctrl+f5 (a complete reload), I get the active script and everything is fine.

       

      I use the following stuff to tune the performance

       

          <context-param>
              <param-name>org.richfaces.LoadScriptStrategy</param-name>
              <param-value>ALL</param-value>
          </context-param>
          <context-param>
              <param-name>org.ajax4jsf.COMPRESS_SCRIPT</param-name>
              <param-value>true</param-value>
          </context-param>
         
          <context-param>
              <param-name>org.ajax4jsf.xmlparser.ORDER</param-name>
              <param-value>NEKO,TIDY</param-value>
          </context-param>
          <context-param>
              <param-name>org.ajax4jsf.xmlparser.NEKO</param-name>
              <param-value>.*\..*</param-value>
          </context-param>

          <context-param>

              <param-name>org.richfaces.LoadScriptStrategy</param-name>

              <param-value>ALL</param-value>

          </context-param>

       

          <context-param>

              <param-name>org.ajax4jsf.COMPRESS_SCRIPT</param-name>

              <param-value>true</param-value>

          </context-param>

       

          <context-param>

              <param-name>org.ajax4jsf.xmlparser.ORDER</param-name>

              <param-value>NEKO,TIDY</param-value>

          </context-param>

       

          <context-param>

              <param-name>org.ajax4jsf.xmlparser.NEKO</param-name>

              <param-value>.*\..*</param-value>

          </context-param>

       

      I doubt the problem results from the configuration in red.

      Please help me out.

      Thanks,

      Ziyang