0 Replies Latest reply on Dec 6, 2010 11:10 AM by Noa Drach

    Message won't deliver on a new queue

    Noa Drach Novice

      I have JBOSS 4.2.3.GA with messaging 1.4.5.GA. java 6

       

      I created a new queue and the message that is sent from the producer doesn't reach my MDB instead I get this error:

       

      java.lang.IllegalArgumentException: wrong number of arguments
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      java.lang.IllegalArgumentException: wrong number of arguments
           at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
           at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
           at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
           at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
           at org.jboss.ejb3.EJBContainer.construct(EJBContainer.java:517)
           at org.jboss.ejb3.AbstractPool.create(AbstractPool.java:66)
           at org.jboss.ejb3.StrictMaxPool.get(StrictMaxPool.java:141)
           at org.jboss.ejb3.stateless.StatelessInstanceInterceptor.invoke(StatelessInstanceInterceptor.java:54)
           at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
           at org.jboss.ejb3.mdb.MessagingContainer.localInvoke(MessagingContainer.java:249)
           at org.jboss.ejb3.mdb.inflow.MessageInflowLocalProxy.delivery(MessageInflowLocalProxy.java:268)
           at org.jboss.ejb3.mdb.inflow.MessageInflowLocalProxy.invoke(MessageInflowLocalProxy.java:138)
           at $Proxy204.onMessage(Unknown Source)
           at org.jboss.resource.adapter.jms.inflow.JmsServerSession.onMessage(JmsServerSession.java:178)
           at org.jboss.jms.client.container.ClientConsumer.callOnMessageStatic(ClientConsumer.java:160)
           at org.jboss.jms.client.container.SessionAspect.handleRun(SessionAspect.java:831)
           at org.jboss.aop.advice.org.jboss.jms.client.container.SessionAspect14.invoke(SessionAspect14.java)
           at org.jboss.jms.client.delegate.ClientSessionDelegate$run_N8003352271541955702.invokeNext(ClientSessionDelegate$run_N8003352271541955702.java)
           at org.jboss.jms.client.container.ClosedInterceptor.invoke(ClosedInterceptor.java:170)
           at org.jboss.aop.advice.PerInstanceInterceptor.invoke(PerInstanceInterceptor.java:105)
           at org.jboss.jms.client.delegate.ClientSessionDelegate$run_N8003352271541955702.invokeNext(ClientSessionDelegate$run_N8003352271541955702.java)
           at org.jboss.jms.client.delegate.ClientSessionDelegate.run(ClientSessionDelegate.java)
           at org.jboss.jms.client.JBossSession.run(JBossSession.java:199)
           at org.jboss.resource.adapter.jms.inflow.JmsServerSession.run(JmsServerSession.java:237)
           at org.jboss.resource.work.WorkWrapper.execute(WorkWrapper.java:204)
           at org.jboss.util.threadpool.BasicTaskWrapper.run(BasicTaskWrapper.java:275)
           at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(PooledExecutor.java:756)
           at java.lang.Thread.run(Thread.java:619)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
      
      

       

      • If I replace the queue I'm using to an exiting queue in my system than the massage is delivered without any problem.
      • I thought that the problem might come from the fact that the producer is an MDB that is restricted using @ActivationConfigProperty(propertyName = "maxSession", propertyValue = "1"), so:
        • I removed the restriction from the producer - no change
        • I added the restriction to the receiver - no change
      • I don't think there is an issue with the queue creation, since 2 queues were added and function just fine.

       

      my suspicion is that there is something wrong with the recieving MDB definition, but I don't know what to look for.

       

      any suggestions?