4 Replies Latest reply on Dec 15, 2010 11:01 AM by Peter Johnson

    JBoss Upgrade from 4.02 to 5.10, .wsr file no longer recognized

    James Chen Newbie

      Hello.

       

      I've recently been trying to upgrade my JBoss environment from 4.02 to 5.10, but it has proven to be a bit more difficult than I had been hoping.  I've gotten through a bunch of issues already, but as my JBoss expertise is very limited (I inhereted the whole system from someone much more JBoss savvy than I), I'm running into problems I'm not sure how to solve.

       

      In the previous 4.02 environment, I could deploy my .ear file, which contained four .jar files, one .war file, and one .wsr file, all of which are denoted as modules in the application.xml.

       

      However, now in JBoss 5.10, when I try to deploy this same .ear file, I get the following message:

       

      2010-12-14 15:13:24,636 ERROR [org.jboss.system.server.profileservice.repository.ProfileDeployAction] (main) Failed to add deployment: Foo.ear
      org.jboss.deployers.spi.DeploymentException: Exception determining structure: AbstractVFSDeployment(Foo.ear)
          at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)
          at org.jboss.deployers.structure.spi.helpers.AbstractStructuralDeployers.determineStructure(AbstractStructuralDeployers.java:85)
          at org.jboss.deployers.plugins.main.MainDeployerImpl.determineStructure(MainDeployerImpl.java:1004)
          at org.jboss.deployers.plugins.main.MainDeployerImpl.determineDeploymentContext(MainDeployerImpl.java:440)
          at org.jboss.deployers.plugins.main.MainDeployerImpl.addDeployment(MainDeployerImpl.java:390)
          at org.jboss.deployers.plugins.main.MainDeployerImpl.addDeployment(MainDeployerImpl.java:300)
          at org.jboss.system.server.profileservice.repository.MainDeployerAdapter.addDeployment(MainDeployerAdapter.java:86)
          at org.jboss.system.server.profileservice.repository.ProfileDeployAction.install(ProfileDeployAction.java:61)
          at org.jboss.system.server.profileservice.repository.AbstractProfileAction.install(AbstractProfileAction.java:53)
          at org.jboss.system.server.profileservice.repository.AbstractProfileService.install(AbstractProfileService.java:361)
          at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:348)
          at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:1631)
          at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:934)
          at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1082)
          at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:984)
          at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:822)
          at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:553)
          at org.jboss.system.server.profileservice.repository.AbstractProfileService.activateProfile(AbstractProfileService.java:306)
          at org.jboss.system.server.profileservice.ProfileServiceBootstrap.start(ProfileServiceBootstrap.java:271)
          at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java:461)
          at org.jboss.Main.boot(Main.java:221)
          at org.jboss.Main$1.run(Main.java:556)
          at java.lang.Thread.run(Thread.java:619)
      Caused by: java.lang.RuntimeException: Error determining structure: Foo.ear
          at org.jboss.deployment.EARStructure.determineStructure(EARStructure.java:293)
          at org.jboss.deployers.vfs.plugins.structure.StructureDeployerWrapper.determineStructure(StructureDeployerWrapper.java:73)
          at org.jboss.deployers.vfs.plugins.structure.VFSStructuralDeployersImpl.doDetermineStructure(VFSStructuralDeployersImpl.java:196)
          at org.jboss.deployers.vfs.plugins.structure.VFSStructuralDeployersImpl.determineStructure(VFSStructuralDeployersImpl.java:221)
          at org.jboss.deployers.structure.spi.helpers.AbstractStructuralDeployers.determineStructure(AbstractStructuralDeployers.java:77)
          ... 21 more
      Caused by: java.lang.RuntimeException: FooServices.wsr module listed in application.xml is not a recognized deployment, .ear: Foo.ear
          at org.jboss.deployment.EARStructure.determineStructure(EARStructure.java:277)

       

      Does JBoss no longer support .wsr files (JBoss Web Service Archive files)?  Has anyone else run into this problem during an upgrade attempt?  I looked in the forums and someone else had a similar problem, but it looked like he just commented out the ".wsr" module section in his application.xml file to fix it, but that would seem to me that I would be losing something valuable that the .wsr file was providing.

       

      Any ideas?

       

      - JC

        • 1. Re: JBoss Upgrade from 4.02 to 5.10, .wsr file no longer recognized
          Peter Johnson Master

          Last time I tried, WSR files were supported. But that was with 5.0.0. Is your web service implemented as an EJB? If so, change it to a JAR file, otherwise change it to a WAR file. Seeing the application.xml might also help.

          • 2. Re: JBoss Upgrade from 4.02 to 5.10, .wsr file no longer recognized
            James Chen Newbie

            Cool, I'll try changing it to the other extension.  But first, lemme post up my application.xml so you can see if there's anything wrong with it while I work on that part.

             

            * * * * * * * * *

             

            <?xml version="1.0" encoding="UTF-8"?>
            <!DOCTYPE application PUBLIC "-//Sun Microsystems, Inc.//DTD J2EE Application 1.3//EN" "http://java.sun.com/dtd/application_1_3.dtd">
            <application>
                <display-name>Foo</display-name>


                <module>
                    <java>FooExceptions.jar</java>
                </module>
               
                <module>
                    <java>FooEJBClient.jar</java>
                </module>


                <module>
                    <java>FooEJBClientWeb.jar</java>
                </module>


                <module>
                    <java>FooServices.wsr</java>
                </module>


                <module>
                    <ejb>FooEJB.jar</ejb>
                </module>


            <!--
                <module>
                    <java>hibernateStartup.sar</java>
                </module>
            -->


                <module>
                    <web>
                        <web-uri>FooWeb.war</web-uri>
                        <context-root>/</context-root>
                    </web>
                </module>
               
                <!--
                <module>
                    <web>
                        <web-uri>FooObjects.war</web-uri>
                        <context-root>/FooObjects</context-root>
                    </web>
                </module>
                -->
            </application>

             

            * * * * * * * * *

             

            Lemme know if that helps any.  Thanks, Peter!  Much appreciated!

             

            - JC

            • 3. Re: JBoss Upgrade from 4.02 to 5.10, .wsr file no longer recognized
              James Chen Newbie

              Well, I no longer see the error now that I've renamed it to a jar file.  I'm running into a different error now and I'll see if I can figure that one out.  If I need more help, I'll definitely be back.  ^_^  Thanks for the help so far, though!  Greatly appreciated!

               

              - JC

              • 4. Re: JBoss Upgrade from 4.02 to 5.10, .wsr file no longer recognized
                Peter Johnson Master

                Glad you got passed this hurdle. I think that the .wsr extension works only for non-EJB web services - it requires the same structure as a .war file, including the WEB-INF/web.xml file. In which case it would be declared the same as a WAR file in the application.xml file.