7 Replies Latest reply on Jan 5, 2011 3:56 PM by Paul Ferraro

    Help with Quick Start

    eric friedman Newbie

      I've been trying to get the mod_cluster 1.1 QuickStart working with no luck. I have 1 box, 64 bit CentOS. I installed the httpd binaries downloaded from JBoss. The app server is 5.1 EAP.

       

      Accessing http://hammond/mod_cluster-manager I get a 404, (http://hammond results in It Works, so my apache config isn't totally wrong.) The load demo does not work either.

       

      In error_log:

      [Tue Jan 04 15:12:36 2011] [notice] Apache/2.2.15 (Unix) mod_cluster/1.1.x mod_ssl/2.2.15 OpenSSL/0.9.8k DAV/2 mod_jk/1.2.30 configured -- resuming normal operations

       

      [Tue Jan 04 15:12:44 2011] [error] [client 192.168.9.5] File does not exist: /opt/jboss/httpd/htdocs/htdocs/mod_cluster-manager

      [Tue Jan 04 15:12:49 2011] [error] [client 192.168.9.5] File does not exist: /opt/jboss/httpd/htdocs/htdocs/load-demo

       

      On the app server side, I copied mod-cluster.sar to the server/all/deploy directory with no changes.

       

      My guess is the problem is with the http configuration. What am I doing wrong? Aside from turning the log level to debug, what can I do for debugging?

       

      Thanks,

      Eric

       

       

      192.168.225.15 is the server.

      The http conf is:

       

      # Adjust to you hostname and subnet.
        Listen 192.168.227.15:80
      # <IfModule manager_module>
        ManagerBalancerName mycluster
        <VirtualHost 192.168.227.15:80>
          <Directory />
           Order deny,allow
           Deny from all
           Allow from 127.0.0
           Allow from 192.168.227
          </Directory>

       

       

          KeepAliveTimeout 300
          MaxKeepAliveRequests 0
          #ServerAdvertise on http://@IP@:6666
          AdvertiseFrequency 5
          #AdvertiseSecurityKey secret

          #AdvertiseGroup @ADVIP@:23364

       

          <Location /mod_cluster_manager>
             SetHandler mod_cluster-manager
             Order deny,allow
             Deny from all
             Allow from 127.0.0
             Allow from 192.168.227
             Allow from 192.168.9.5
             AllowDisplay On
          </Location>

       

        </VirtualHost>

        • 1. Re: Help with Quick Start
          Paul Ferraro Master

          You defined the mod_cluster manager at "/mod_cluster_manager", yet you tried to access "http://hammond/mod_cluster-manager". (i.e. "-" vs "_").

          That would explain the 404.

          1 of 1 people found this helpful
          • 2. Re: Help with Quick Start
            eric friedman Newbie

            Thanks Paul! That did explain the 404. But there seems to be a disconnect between the node and the mod_cluster manager. When accessing the url from the browser, the status looks fine, but there is no node information:

             

            mod_cluster/1.1.x

            start of "httpd.conf" configuration
            mod_proxy_cluster.c: OK
            mod_sharedmem.c: OK
            Protocol supported: http AJP https
            mod_advertise.c: OK
            Server: hammond.navicure.com
            Server:  hammond.navicure.com VirtualHost: 192.168.227.15:80 Advertising on  Group 224.0.1.105 Port 23364 for http://192.168.227.15:80 every 5  seconds
            end of "httpd.conf" configuration

             

            I started JBoss with -u 224.0.1.105, and it should use the default port of 23364. But when I run the Quick Start client (with the target 192.168.227.15:80), the request fails. Apache is trying to service the request instead of forwarding it to the JBoss node:

             

            [Wed Jan 05 10:23:56 2011] [error] [client 192.168.9.5] File does not exist: /opt/jboss/httpd/htdocs/htdocs/load-demo

             

            When I change the target port on the client to 8080, the app server handles the request as expected.

             

            2011-01-05 10:33:02,586 INFO  [org.jboss.modcluster.demo.servlet.ActiveSessionsLoadServlet] (http-192.168.227.15-8080-21) Handling session load request from: http://192.168.227.15:8080/load-demo/sessions, using session id: af008yGiyatx5YN9dRgsCg__

             

            The network is configured to support multicast:

             

            eth1      Link encap:Ethernet  HWaddr 00:14:22:4A:5C:27
                      inet addr:192.168.227.15  Bcast:192.168.227.255  Mask:255.255.255.0
                      inet6 addr: fe80::214:22ff:fe4a:5c27/64 Scope:Link
                      UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1

             

            I've been over the configuration a number of times, not to say I haven't missed something. Any idea what I am missing any tips for troubleshooting?

             

            Thanks,

             

            Eric

            • 3. Re: Help with Quick Start
              Paul Ferraro Master

              So, you're using advertise to broadcast your load balancer's existence to the EAP nodes.  Are you certain that you have mod_cluster.sar deployed on your EAP nodes?  Can you make sure that advertise is enabled on the EAP nodes themselves (look for the advertise property in the ModClusterConfig bean within mod_cluster.sar/META-INF/mod_cluster-jboss-beans.xml)?  [Forgive me, but I gotta ask the dumb questions first...]

              Does the mod_cluster.sar service start successfully?  If you enable DEBUG logging for "org.jboss.modcluster", do you see any log messages indicating the receipt of the advertise multicast messages from the load balancer?

              1 of 1 people found this helpful
              • 4. Re: Help with Quick Start
                Paul Ferraro Master

                Also, have you tried defining an explicit proxyList for your EAP nodes (as an alternative to advertise)?  You can define this either via the proxyList property of the ModClusterConfig bean within mod_cluster.sar/META-INF/mod_cluster-jboss-beans.xml, or via the jboss.mod_cluster.proxyList system property.

                • 6. Re: Help with Quick Start
                  eric friedman Newbie

                  Thank you Paul. Everything looked good and I could see that the sar was deployed in the JMX console, but when I enabled debug, I saw nothing. Note that I'd been using the EAP software.

                   

                  I replaced the eap sar with the open source version and it worked fine with the Quick Start client.My guess is the commercial code works too, but we could not find the documentation for it. It probably needs additional configuration. My mistake was assuming the open source docs would work for it.

                   

                  Eric

                  • 7. Re: Help with Quick Start
                    Paul Ferraro Master

                    N.B. The EAP sar uses 1.0.x of mod_cluster.  I doubt that this version is compatible with the 1.1.x version of the httpd modules.